HELP:2009 White Macbook Wifi Issues OSX Lion

Discussion in 'macOS' started by sahpreemking, Oct 16, 2011.

  1. sahpreemking macrumors newbie

    Joined:
    Oct 16, 2011
    #1
    I have a mid 2009 white mac book, here are the specs:
    2.13 GHz dual core processor
    4GB 800Mhz ram
    OSX 10.7.2
    Internet connection is Comcast

    Here is the issue. Ever since I updated to Lion, I have not been able to get an internet connection higher that 1.00Mps. Before updating my normal download speed was between 15-18Mps without any issues. I updated to 10.7.1 and it fixed nothing. Just updated to 10.7.2 and it still doesn't function properly. I have a Macbook Pro and it works fine, connected to the same router and downloads around 15-18Mps. I have tried multiple suggestions recommended by users on this site, but nothing seems to work and the last thing I do is want to clean install an older OSX.

    SOMEONE PLEASE HELP ME
     
  2. satcomer macrumors 603

    satcomer

    Joined:
    Feb 19, 2008
    Location:
    The Finger Lakes Region
    #2
    First try to Reset Your PRAM to see if that helps. If not then try these steps:

    1) Open System Preferences->Network and turn of you Airport card.

    2) In the left hand pane (while the airport card is still highlighted) and click on the - symbol. Don't Panic because you will add it back.

    3. Close down System Preferences and restart.

    4. Upon the restart open System Preferences->Network again and click the + button to add your Airport card back in. Don't forget to click the 'Apply' button in the right hand pane of the Airport card to save this new card setting.

    5. The new Airport card display is still showing Join your wireless network again.

    See if these steps help, Good Luck.
     
  3. sahpreemking thread starter macrumors newbie

    Joined:
    Oct 16, 2011
  4. hypermotion, Mar 15, 2013
    Last edited: Mar 15, 2013

    hypermotion macrumors newbie

    Joined:
    Mar 15, 2013
    #4
    Success :]

    It did work for me .. I mean the remove airport > add airport part (reseting PRAM didn't work).
    No problems now (my friend's white mackbook 2.4GHz, 4GB RAM).
    -ups sorry .. it got better but i still have problems (downloaded 500 MB of update file and it slowed down again)
     

Share This Page