HELP:: 3Gs stuck in Restore error 1015 loop

Discussion in 'iPhone Tips, Help and Troubleshooting' started by ryanlyma, Jan 5, 2011.

  1. ryanlyma, Jan 5, 2011
    Last edited: Jan 6, 2011

    ryanlyma macrumors newbie

    Joined:
    Jan 5, 2011
    #1
    I have an iphone 3Gs, 4.2.1 Jailbroken and unlocked.
    It was unlocked by a third person, and he told me do not ever restart the phone bc it was unlocked.
    I did accidentally.

    I tried to restore it but error 1015 occurred. It seems that I am in the "error 1015" loop -- whether I restore from recovery mode or DFU mode, I still end up with 1015.

    I tried to use tinyunbrella to retrieve my SHSH or ECID, didn't work.
    I tried to use RecBoot to kick it out of recovery mode, didn't work either.


    What should I do to resurrect this brick?
    Plz guide. And please feel free to ask any questions.

    Million Thanks!!!!!

    ----------------------
    Update:

    What I am missing I think is the SHSH. I never saved it before... Is there any way of retrieving it? Or am I completely screwed?
     
  2. b1234k macrumors newbie

    Joined:
    Jan 10, 2011
    #2
    Even I am facing the same issue


    Even I am facing the same issue, please help. I have my shsh stored with 4.2.1. Pleasee help.
     
  3. danielp macrumors newbie

    Joined:
    Mar 7, 2011
    #3
    The problem is that you have upgraded the baseband to 06.15.00 (which is from the iPad) instead of the iPhone baseband of 05.15.04. Currently there is no way to downgrade the baseband 06.15.00 (although MuscleNerd seems to be working on it), so iTunes cannot restore any official IPSW.

    In order to restore, you absolutely need to get a custom IPSW. This is beyond this thread, but just google "custom 4.2.1 IPSW" and you shall find :)
     
  4. Crystal-RX macrumors 68030

    Crystal-RX

    Joined:
    Dec 22, 2008
    Location:
    Seattle, WA USA
    #4
    Your phone has a tethered jailbreak before Greenpois0n come out. So, hook it up to your PC, run Redsn0w 0.9.6b6 and boot it up.

    Once you done, run Greenpois0n over it and you have a untethered jailbreak where you can turn off the phone freely.
     
  5. danielp macrumors newbie

    Joined:
    Mar 7, 2011
    #5
    I don't think the jailbreak is the problem here. Error 1015 is a baseband error and it comes from the unlock. Unlocking was easier for baseband 06.15 than 05.15.04, so unlockers needed to upgrade the baseband. There is currently no way to downgrade it unfortunately, so you'll probably need a custom IPSW file to restore, even greenpoison will not be able to finish the jailbreaking.
     
  6. gccshrey macrumors member

    Joined:
    May 1, 2010
    #6
  7. Crystal-RX macrumors 68030

    Crystal-RX

    Joined:
    Dec 22, 2008
    Location:
    Seattle, WA USA
    #7
    At the beginning, it was the jailbreak issue due to tethered jailbreak. However, OP tried to restore it and he/she facing the current problem due to Ipad baseband.
     

Share This Page