Help - 3GS will not restore

Discussion in 'iPhone' started by Hallsy, Oct 31, 2012.

  1. Hallsy macrumors newbie

    Joined:
    Oct 31, 2012
    #1
    Hi guys,

    newbie here :)

    A little while ago I was given a 3GS to take a look at, the symptoms at the time were that it would keep rebooting. It sat in a drawer until the battery went flat, and then it seemed to have troubles taking a charge. It would boot, but not really charge properly.

    Battery died, and then it would not boot at all or charge. At that point I tried to restore it by entering DFU mode, and amongst various errors, the most common was 1604. It seemed to have trouble when the device was rebooted during the restore process. Decided the battery could be u/s, so I bought a new one, have fitted that and it is still the same.

    So basically, it won't take a charge, but does know it has a charger connected as it goes from 'blinking' red battery, to sold red battery.

    It seems to have USB issues, when I first put it in USB mode my laptop (XP) doesn't recognise it, but if I unplug and use a different USB port, itunes will go into recovery mode. Then, during the process, it will reboot the device, windows pops up with USB not recognized, and I will eventually get a 1604 error (usually).

    At home on another laptop (Win7), it seems to detect it OK first time, but still faults out in the same way during the restore process.

    I've tried three laptops and two leads.

    Any ideas on this one?? I have another 3GS that I may try swapping spares between, my next port of call will be the dock connector, before accusing the logic board.

    Any suggestions would be much appreciated :)
     
  2. Hallsy thread starter macrumors newbie

    Joined:
    Oct 31, 2012
    #2
    Oh, forgot to add, one time I left it plugged into my laptop, after a failed restore and randomly the phone had booted up and was working (the restore hadn't been completed, it had booted up with an older ios).

    Stupidly, I then tried to restore it again as I thought the phone had sorted itself out, but now I'm stuck in the won't boot & won't restore loop again!!
     

Share This Page