Help a Mac newbie out: transmission protocol?

Discussion in 'Mac Basics and Help' started by = bluntman =, Oct 26, 2009.

  1. = bluntman = macrumors regular

    Joined:
    Sep 15, 2009
    Location:
    Toronto, Ontario
    #1
    My Mac shares a NAS drive with two other Windows computers. All computers can access the NAS drive, however, the problem arises when I transfer photos (via card reader attached to my Mac) to the NAS drive.

    Normally, I would open up the NAS drive in Finder and create a new folder for the new photos. As soon as the CF card (in the card reader) appears on my Mac's desktop I would transfer the files from the card over to the new folder on the NAS. Sounds simple, but for some reason, those newly transferred files do no appear on the Windows machines when they try to access that particular folder! The Windows machines can see the new folder, but none of its contents.

    What gives?

    According to the manufacturer of the NAS drive (QNAP) "there's a known issue that AFP transmission will cause the folder/file not to be seen" and "to avoid this problem, we'll suggest that to use the same transmission protocol in a folder. (Ex. avoid to use AFP & SMABA to the same folder)".

    I guess I am using AFP to transfer the files from the card to the NAS, so the question is, is there another way to transfer the files so the Windows machines can automatically see the files?

    Thanks in advance!
     
  2. jzuena macrumors 6502a

    jzuena

    Joined:
    Feb 21, 2007
    Location:
    Lexington, MA, USA
    #2
    If you attach to the drive using smb:// at the beginning of your URI instead of afp:// it will use Samba so that it is compatible with the Windows boxes.
     
  3. = bluntman = thread starter macrumors regular

    Joined:
    Sep 15, 2009
    Location:
    Toronto, Ontario
    #3
    I use Automountmaker (with SMB) to access the NAS on my Mac. However, the NAS actually shows up twice on the left panel in Finder. As an SMB mounted drive, it is identified by its IP address. As (I believe) an AFP mounted driver, it shows up by it name. Is there a way to remove the second instance?

    I'm confused!
     
  4. jzuena macrumors 6502a

    jzuena

    Joined:
    Feb 21, 2007
    Location:
    Lexington, MA, USA
    #4
    I'm not sure how you would get rid of the second afp instance in the Finder, but can you just turn off the afp protocol on your NAS? I have a Promise SmartStor NAS and it has a web-based setup utility where I can turn different protocols on and off. Maybe the QNAP has a similar setup screen?
     
  5. = bluntman = thread starter macrumors regular

    Joined:
    Sep 15, 2009
    Location:
    Toronto, Ontario
    #5
    Thanks, I will investigate.

    Of course QNAP has posted a workaround for this problem, but it involves logging into the NAS via SSH and entering a command line instruction, but I don't want to do this everytime I transfer new photos to the NAS.
     
  6. = bluntman = thread starter macrumors regular

    Joined:
    Sep 15, 2009
    Location:
    Toronto, Ontario

Share This Page