Help ! About Iphone Provisioning Portal.

Discussion in 'iOS Programming' started by cthesky, Oct 26, 2011.

  1. cthesky macrumors member

    Joined:
    Aug 21, 2011
    #1
    Hi,

    Recently, I tested my Iphone project over my Ipad (IOS 4). I done all the steps in Iphone Provisioning Profile. For the first section "Certificates" , I remembered that I request an individual iOS Development Certificates. Then, I had successfully installed my Iphone apps into my Ipad.

    But the next day, I tested my Iphone project over my another Ipad (with IOS 5 but my Xcode is using IOS 4.3). So, in the Iphone Provisioning Profile there, I not repeat all the steps. What I done at there is I just add New Devices under "Device" section and then modify IOS Development Provisioning Profile by select a new device I just registered and then import this Provisioning Profile into the Organizer-Provisioning Profiles of my device again. But I failed to test my project over this Ipad... There is yellow dot beside my device in Organizer... I don't know why... Am I doing something wrong ?

    And one more thing is I remember that so far I just requested an individual iOS Development Certificates... But what I noticed is... in Iphone Provisioning Profile, under "Certificate - Distribution", it also contains a certificate. And the expiry date for this distribution certificate is not same with the development certificate... I really confused... Is the distribution certificate created automatically?

    Now, I feel confused... Can I remove all the things and start over again? That is remove all the certificate, device id, provisioning profile in Iphone Provisioning Profile.

    I really need some help. Hope someone can reply me. Any comments and suggestion are welcome. :)

    Thanks a lot.
     
  2. dejo Moderator

    dejo

    Staff Member

    Joined:
    Sep 2, 2004
    Location:
    The Centennial State
    #2
    I'm pretty sure that in order to deploy to a 5.x device you need to have Xcode 4.2 installed. You never stated which version of Xcode you're using.
     
  3. cthesky thread starter macrumors member

    Joined:
    Aug 21, 2011
    #3
    Thanks for your reply.:) I am using Xcode 4.0.2 with IOS Sdk 4.3.
     

Share This Page