Help! After restart for software update, my MBP boots to Steup Assistant.

Discussion in 'Mac Basics and Help' started by avincent52, Dec 23, 2007.

  1. avincent52 macrumors regular

    Joined:
    Nov 6, 2007
    #1
    UPDATE
    I did some searching after I posted and found that others had the same problem with a Setup Assistant loop.

    Below is the quick and easy solution courtesy of OS 11--which evidently worked when reloading the software did not.
    I experienced no data loss, only a strange glitch which replaced my desktop image with another version from Aperture. But all the important stuff, including the documents I was using when it crashed, are safe and sound (and being backed up as we speak)

    So while I am grateful for the collective expertise here, I'm annoyed at Apple that I'm having to use it more and more. Do contractors have to search the DeWalt Cordless Drill Forum to get *their* tools to work?

    THE ANSWER

    So here are the STEPS if you get caught in the Leopard Setup Assistant Loop Bug ---

    1) Boot into Safe Mode by holding down the shift key upon boot... (wait, wait, wait... it will finally come up)
    2) DO NOT LOG IN
    3) Hit the back arrow key
    4) Then hit the restart button
    5) Wait, it will then run/rerun the updates
    6) Wait, wait, wait and it will finally restart...

    Then you are back to normal without any data loss...


    MY ORIGINAL QUESTION
    Good people
    I just installed the latest Safari security update on my almost new MBP, which is running Leopard.
    As I was closing out of Word preparing for a shutdown, the cursor froze (as it has been doing although not as often since the last software patch)
    I restarted the computer with the on-off button, and it booted to Setup Assistant, as though I had just taken the computer out of the box. I tried quitting setup assistant and it gave me nothing but a blue screen without a toolbar or anything on the desktop.
    I didn't go any further than the "which language?" prompt for fear of overwriting data or settings.
    I've done dozens if not hundreds of software updates on this machine and two other macs and needless to say, this has never happened before?
    What should I do?
    Am I up the proverbial creek without the figurative paddle?
    Thanks in advance
    Allen
     
  2. Eraserhead macrumors G4

    Eraserhead

    Joined:
    Nov 3, 2005
    Location:
    UK
    #2
    I think the software update has failed, possibly due to the machine switching off during the update. (It happened to me yesterday :rolleyes:), I suggest you continue the process and if it loops then reinstall Leopard with an Archive and Install and that should be OK and you should still have your data, of course you should have a time machine backup.

    EDIT: Ok there is a better way clearly.
     

Share This Page