Help - all my icons are missing and I can't shut down!

Discussion in 'iMac' started by steevg, Mar 3, 2009.

  1. steevg macrumors member

    Joined:
    Aug 5, 2008
    #1
    Would really appreciate some help here please!

    Working away merrily the other night, when I decided that I needed a multiway power socket in my room. Trouble was, my G4 iMac (flat screen) was plugged into the power socket.

    Logged out, shut down, waited until the hard drive stopped spinning, then pulled the plug from the wall.

    Ok no problems so far . . . . .

    Plugged in the new multi-way extension socket, and restarted my iMac.
    Once it had fully booted, I noticed - no dock.
    Went to check the main drive (via icon top right hand corner of the desktop), and pulled up my finder window . . .. lo and behold . . . no icons in the left-hand side of the window. All my Mackintosh HD files were there (Documents, Library etc), but no left-hand window icons (Documents, Home folder etc).

    I've done all the usual stuff, rebooted, cleared out some of the old junk on the HDD, run disk utility etc etc, but still no dock or Icons!!!

    Looks like all my docs and music etc are available, but I can't shut the iMac down either now - nothing happens when I go to Log-Out or Shutdown!

    Any idea's guys please???

    Thanks in advance!
     
  2. SHADO macrumors 6502a

    SHADO

    Joined:
    Aug 14, 2008
    Location:
    Beach
    #2
    Well you can force shut it down by holding down the power button until it turns off. The first thing I would do is BACK EVERYTHING UP using an external HD. Then I would (assuming you have already repaired permissions using Disk Utility) boot into single user mode by holding down command+S on startup. This will bring you to a black screen that looks like Terminal (it's called Darwin). Then type "fsck -fy" (without quotes). This will do a disk check. If everything comes out ok, then type "reboot" (again, without quotes) and it will restart your mac. Then I would try using DiskWarrior or Drive Genius 2 to de-frag your directory and hopefully that will help.
     
  3. steevg thread starter macrumors member

    Joined:
    Aug 5, 2008
    #3
    Shado,

    great stuff, thanks for the help.
    I'll give it a go tomorrow evening.
    Was going to backup everything, but lost my firewire cable, so will get one!
    Regarding the disk check - yes i've done this before, but forgot the "fsck -y" command, and the reboot command. So now you;ve provided that I can try it.

    Didn't know about Diskwarrior, but will also do a search and try it before doing anything drastic.

    Once I've backed up, and tried all the above, it's possible that a reinstall of 10.4 might be the only way to fix it! Never done a reinstall (only a fresh install).
    How easy is it to ensure I don't loose any data during this? Is there an Archive and reinstall or something? If so what does this do exactly?

    Thanks again.
     
  4. SHADO macrumors 6502a

    SHADO

    Joined:
    Aug 14, 2008
    Location:
    Beach
    #4
    Well if you back everything up (assuming you find your FireWire cable :p), it's very easy to restore everything from the backup. This link might be helpful to you also (it's about archive and install). But make sure you back up everything first, even though it is very unlikely you will lose any data during this process. Better to be safe than sorry. Good Luck.
     

Share This Page