Help! All of my photos have disappeared on iPhoto but appear on Spotlight!

Pokikol

macrumors newbie
Original poster
Oct 4, 2006
4
0
All my photos have disappeared from iphoto, and that means all my pics of my twins and last baby of 8months old! I searched for them and they appear in my iphoto library but I can't drag and drop them back on iphoto since a pop up says "the following files have not been imported (they may not contain valid data or it is impossible to recognize the type)"
I searched for jpeg on spotlight and all my pics show up but I can't copy them on a DVD since they become alias and are reduced to 40 k.
Is there anyway I can find them (the originals) and restore them back into iphoto or save them on a DVD?
I hope this is clear, I am a beginner with Mac. Thanks for any help
Pokikol
 

gavd

macrumors 6502a
Jan 30, 2006
602
2
Pokikol said:
... but I can't copy them on a DVD since they become alias and are reduced to 40 k.
Have you tried copying them to a DVD whilst holding down the Alt or Apple Key (can't remember which). I think this should make a copy of the files rather than turning them into Alias's.

I know this doesn't help with your problem as such but hopefully it will help you save the images.
 

deebster

macrumors 6502
Oct 21, 2004
276
0
Olde Englande
Using the finder have a look in

Users>(your user name)>Pictures>iPhoto Library

Maybe press command-I or click the Get Info blue button and see what size your iPhoto Library is. If it's less than 4.3 GB you can bun it to DVD. You can use The Finder's Burn folder for that, or insert a blank DVD and drag the folder to it.

Apologies if some if this is obvious to you, but you said you were new to Macs :)

It sounds like iPhoto is not recognizing your Library for some reason. You could try holding the option key when launching iPhoto and see if it asks you to select your Library folder, but I'd burn that DVD first if it were me.
 

Pokikol

macrumors newbie
Original poster
Oct 4, 2006
4
0
Still haven't recuperated photos

Hello all and thanks for your help

Munkle, I followed the steps in the article you mentioned, thus used the utility disk to repair HD and permissions and all went well. Then I launched iphoto while holding down comand and option key and asked it to reconstruct the data base in iphoto phototèque (sorry translating from french here) and it says (phototeque is located on a locked disk where I don't have the permission to apply changes". So I'm stuck here. Any ideas??? Where should I go from here? How do I unlock those permissions?

Gavd: I tried both, holding command key or option key, it didn't work, still copies alias.

Deebster: thanks for the advice, I did try to do that but as I mentioned in my initial post, I only get alias files when I do that, thus my pics are reduced to 40k.

Hope you all have other options
Thanks loads
Pokikol
 

ryanfar

macrumors newbie
Jan 6, 2013
1
0
Hello all and thanks for your help

Munkle, I followed the steps in the article you mentioned, thus used the utility disk to repair HD and permissions and all went well. Then I launched iphoto while holding down comand and option key and asked it to reconstruct the data base in iphoto phototèque (sorry translating from french here) and it says (phototeque is located on a locked disk where I don't have the permission to apply changes". So I'm stuck here. Any ideas??? Where should I go from here? How do I unlock those permissions?

Gavd: I tried both, holding command key or option key, it didn't work, still copies alias.

Deebster: thanks for the advice, I did try to do that but as I mentioned in my initial post, I only get alias files when I do that, thus my pics are reduced to 40k.

Hope you all have other options
Thanks loads
Pokikol

Hi I have the same problem when i click on the photos on iphoto they come with ! exclamation mark and you can't copy them can you please help me what you do if you have the same problem please

Regards
Ryan
 

RoelJuun

macrumors 6502
Aug 31, 2010
426
165
Netherlands
Whenever Spotlight can still find it, it still is on your disk. Therefore type in Spotlight the name of a photo, hold cmd and hit enter. You are presented with the enclosing folder of the photo.
 

WilliamDu

macrumors regular
May 22, 2012
146
46
Disappearing Photos

I have same problem.
All my photos went away on 1/1/2013.
This is a fatal flaw in Apple's software and they owe users an explanation and a fix.
I'm struggling with trying to locate them on external hard disc backup made some months ago, but TM can't find them.
Photos made since last backup to external disc apparently gone.
Where is Apple when their system screws up?:mad:
 

benwiggy

macrumors 68020
Jun 15, 2012
2,186
15
This is a fatal flaw in Apple's software and they owe users an explanation and a fix.
Where is Apple when their system screws up?:mad:
It's far from clear that is an actual bug in the software. Perhaps if this happened to a large proportion of Mac users, then there might be a case.

If you can find them with Spotlight, then they are still on the disk. It's much more likely that the Library file has been moved, rather than all the photos being deleted.

You say they are not on Time Machine either? At all? Even a snapshot from November 2012? That sounds very odd.