Help allowing outgoing connections? (SSH, FTP, MySql server)

Discussion in 'Mac Basics and Help' started by GelleCC, Jan 28, 2012.

  1. GelleCC, Jan 28, 2012
    Last edited: Jan 28, 2012

    GelleCC macrumors regular

    GelleCC

    Joined:
    Jul 13, 2008
    Location:
    Seattle, WA
    #1
    I've been having this problem for some time now and I'm not really sure what's caused it. I used to be able to ssh from my macbook to my school's servers using terminal, fugu, cyberduck, and filezilla.

    I updated to snow leopard on a Macbook1,1 intel core duo (late 2007 early 2008 model) Now, it wont connect using any of the things above and including mySql workbench. I get "Connection refused".

    I really need to use mysql for school (Sql development, not admin or modeling under the workbench), but I cant access the server. I keep getting this error:

    Your connection attempt failed for user 'xxxx' from your host to server at xxxx.yyyyy.zzzzz.edu:3306:
    Can't connect to MySQL server on 'xxxx.yyyyy.zzzzz.edu' (61)


    The error is similar trying to ssh/sftp - the connection just refuses.

    I've changed the names of the user/server to protect the innocent. The settings to access the server are correct (I've quadrouple checked spelling). It just wont connect. I think it has something to do with the firewall? I've tried accessing it with the firewall turned off and turned on with mysql allowing incoming connections. Under System Prefs > sharing > I have file sharing, web sharing, remote login, remote management.

    Is there something else that I need to do? Maybe under system prefs > network? Under network > advanced > proxies, nothing is checked except "Use passive ftp mode" at the bottom.

    Edit:
    More settings. I just checked my router settings to see if that might be a problem (to be honest - I don't really know what I'm looking for? But I checked the "security" tab).
    Linksys wrt54g2 router:
    Under security > firewall >
    Block anonymous internet requests CHECKED,
    filter multicast CHECKED,
    filter IDENT(port 113) CHECKED,
    the only one not checked is filter internet NAT redirection.
    Under application and gaming > port range forwarding/port triggering
    Haven't touched these settings so they are the defaults
    under application and gaming > DMZ/QoS
    Disabled
    Under Administration > management
    Access server: HTTP Checked
    HTTPS NOT CHECKED
    Wireless Access web: Enable
    Remote management: disable
    Management port: (Grayed out but says) 8080
    Use HTTPs: NOT CHECKED
    UPnP: Enable

    I can get on the internet fine (from a variety of devices - ps3, macbook, iphones, etc). I don't know if this will help, but I've also tried to set up PS3 Media server to stream from my macbook to ps3, but it never works either (gave up a long time ago but thought I'd throw that in for some extra info).
    I'd really like to get this fixed so I don't have to go on campus every time I do my homework. Any help is much appreciated.

    -Corey
     
  2. Skyrim macrumors member

    Joined:
    Dec 13, 2011
    #2
    The port may be blocked. Have you checked it?
     
  3. GelleCC, Jan 29, 2012
    Last edited: Jan 29, 2012

    GelleCC thread starter macrumors regular

    GelleCC

    Joined:
    Jul 13, 2008
    Location:
    Seattle, WA
    #3
    I have not. I actually don't know how? Would it be through the application (MySQL workbench) or something in my system prefs or the router?

    The port from the workbench is 3306 (and works from campus computers/friends computers).

    From cyberduck and the like, I try to ssh from port 22 (which, again, works from campus/other computers).

    As far as allowing the connections in System Prefs > Security > firewall > advanced, I have added both MySQL workbench and the ftp programs. The only options, though, are "allow incoming connections" and "disable incoming connections". I need outgoing, thought, not incoming.

    And how would I go about allowing it?
     
  4. Skyrim macrumors member

    Joined:
    Dec 13, 2011
    #4
    You can go to System Prefs > network utility > port scan and check the open ports. Since other computers can connect to the SQL server without problem, the server is working in order. The problem will be at your computer or the network routing. To further check this, you can try the friend’s computer with your network connection.
     
  5. GelleCC, Jan 30, 2012
    Last edited: Jan 30, 2012

    GelleCC thread starter macrumors regular

    GelleCC

    Joined:
    Jul 13, 2008
    Location:
    Seattle, WA
    #5
    Do I type in the host server into the "enter an internet or IP address to scan for open ports" field? I did that and it returned nothing.

    Funny thing is I pulled out the macbook air and logged into the server just fine. The macbook was wiped clean a few months ago and I haven't touched it till now. However, the settings were almost identical to my macbook that I'm currently using (that wont login to the server)...
     
  6. GelleCC thread starter macrumors regular

    GelleCC

    Joined:
    Jul 13, 2008
    Location:
    Seattle, WA
    #6
    Problem solved.

    I booted in safe mode and ran the mysql workbench and it worked just fine. So... I thought I'd take it to apple to see if they could figure it out. After waiting for the genius do everything I had already done, he concluded that it was some 3rd party app that might be blocking the connections and that I do a complete wipe (no way, ALL my work wont fit on my external HDD), an Archive and install (which will put the settings back to normal (if it was a setting problem vs the third party app problem - so this might not have fixed the problem), or hunt for a third party app on my own.

    So I hunted. I went through every third party app that I thought might block connections (like ps3 media server, air mouse server, sophos antivirus, etc). Deleted them one by one, rebooted each time to test if mysql worked and finally found the problem. It wasn't an app that even should be connecting to the internet... iStatPro. I would uninstall the app, test mysql, reinstall the app if the problem wasn't fixed (except for the antivirus, just completely got rid of that).

    TL;DR - if you're having a problem with connections, check the login items or 3rd party apps. Mine was caused by the iStatPro dashboard widget.

    Thanks, @Skyrim, for the help.
     

Share This Page