HELP: Anyone have iCall?

Discussion in 'iOS Apps' started by Master Debater, Sep 15, 2009.

  1. Master Debater macrumors member

    Joined:
    Jul 30, 2008
    #1
    I downloaded iCall for my iPod touch and it works fine, except I want to change the mobile phone number I used to register with it (the number that shows up on the caller ID). After failing to get in touch with support, I decided the best solution was to reset my account and just make a new one.

    However my iCall account profile has my specific iPod device code bound with the account. Anyone know a way to 'unbind' my device with the service?

    Maybe the new iPhone Configuration Utility would be useful for this? I have no idea

    [​IMG]
     
  2. unfrozen.jon macrumors member

    unfrozen.jon

    Joined:
    Sep 23, 2007
    Location:
    Canada
    #2
    I had iCall for three months, its unlimited calling plan and I cancelled after not being able to ever make a successful call. I had been waiting months for it because it looked so promising then when it came out I immediately got the unlimited plan, tried to use it but call always failed. I could check my voicemail so I assume it could connect to their service but I made sure none of my ports that is uses were blocked.

    Gave up on that, went away for work for a month and tried it at several wifi networks secured and open and it always failed. I emailed support about it. No answer.

    Got busy and didn't look into again til I got home the next month (its second month of the unlimited plan already charged to me). I once again emailed support, as well tried unlbocking more ports, uninstalling and reinstalling. No joy.

    Forgot about it when I had to go away for another few weeks (there was no connections where I went) and when I got home no email reply from support but the third month had been charged to me.

    I was pissed, I sent them a threatening email and said I would cancel and never use their service again as of the last day before the next billing cycle if I had not received a reply. No reply, three months I subscribed to their unlimited plan and never made a single call. Partly my fault but I was busy and figured it was a simple configuration problem.

    My suggestion is don't waste your time with them but hey if it ends up working for you without having to get an answer from customer service you could luck out.
     

Share This Page