Help - Apple IDs a Mess!

Discussion in 'iOS 5 and earlier' started by iPhone3gPSU, Oct 12, 2011.

  1. iPhone3gPSU macrumors member

    Joined:
    Jun 12, 2009
    #1
    So I really don't think anyone has posted this specific problem, forgive me if I missed it (I know how you all can be! :p)

    I had two Apple IDs, like any of us who had MobileMe. I wanted to change my iTunes/App Store ID verified e-mail to something else so that I could register my that e-mail address on my me.com Apple ID. With me so far??

    Well, now I can't register my main me.com address ANYWHERE! I checked the old apple ID on Apple's My Apple ID site and the new e-mail address is verified. However, when I go to verify it on my me.com Apple ID account, I get an error saying that the e-mail addresses is verified on another account. Help!! :mad:

    Anyone else in this same situation? There also isn't any way to really contact anyone for help! :confused: :confused:
     
  2. chrismac2 macrumors regular

    chrismac2

    Joined:
    Jan 14, 2008
    Location:
    Renton, WA
    #2
    I'm in the exact same situation. I have an old iTunes store account, which is not an email address, so I had my mobile me email as the primary email on the iTunes store account.

    So I made the mistake of trying to use my MobileMe apple ID on iMessage instead of my iTunes Apple ID, and it won't let me use the mobile me email, saying that it's already in use.

    So I went to appleid.apple.com and removed the MobileMe address from my iTunes store account, put a different email there....verified it. But it still won't let me put the MobileMe email address on my MobileMe Apple ID, it says it's still in use, even though I know it's not. It won't even let me add it back to the iTunes store account. Now it's all F'd up and I can't use the MobileMe email with any Apple ID :-(

    I'm hoping that maybe it just takes time to reset and I'll try again tomorrow, but I'm not going to hold my breath. I read someone on another forum that they were able to get it resolved through MobileMe support, but it took like 3 weeks to get it all resolved :mad:
     

Share This Page