Help, Apple TV 2 "Authorization is Required"

Discussion in 'Apple TV and Home Theater' started by YsoSerious, Sep 30, 2011.

  1. YsoSerious macrumors 6502

    YsoSerious

    Joined:
    Oct 8, 2008
    #1
    Started having problems with apple tv 2 authorization is required when trying to play movies on my mac via home sharing. Tells me to go into itunes and authorize it to play movies. I did this and have 2 out of my 5 devices authorized to play. It works when I go into itunes on my mac and play the movie then switch it to the apple tv. I get the erro message when I access my mac on apple tv under computers and try to play a movie.
     
  2. DFlaze macrumors newbie

    Joined:
    Feb 18, 2011
    Location:
    Washington, DC
    #2
    Second

    I also have started to notice this on my almost year-old ATV2. I've re-checked many times to make sure that it's anything but the Apple TV unit, but it looks like it is.

    However, I've also noticed why it may have trouble recognizing your Apple TV as an authorized device. When i go to Settings>General>Sign in and attempt to sign in using my Apple ID and password, i get an error stating that the "Network time cannot be set." For some unknown reason, the Apple TV is connected to the internet, but cannot set the time zone and, i believe most likely for DRM reasons, will not allow the user to fully sign in. Note that everything else, for me anyway, is working as it should: Netflix works, non-iTunes purchased content, such as movies and TV shows, play perfectly, and photos stream through perfectly. It is ONLY iTunes-purchased content with DRM that will not play. Oddly, I can AirPlay this content to the ATV2 from my MacBook without errors or authorization obstacles, which is exactly as you describe.

    I've been looking through other forums, discussions, etc. but haven't found an answer from Apple people other than the standard "reset everything" responses. I hope this is fixed once the next ATV update is rolled out, whenever that may be.
     
  3. Homefly macrumors newbie

    Joined:
    Sep 30, 2011
    #3
    Same problem started today

    I have the exact same issue. It happens on both my Apple TV2's. I can play iTunes content fine from the shared library from my Mac Mini to my iTunes client on my extra PC, and on my iPad2. I just can't get either of my Apple TV2's to work with my DRM'd iTunes content when I try to launch it directly from the Apple TV. Other stuff plays just fine. AirPlay of iTunes content plays just fine on the Apple TV's. I reset the Apple TV's and restored them, with no change. I reinstalled iTunes on the Mac, no change. Deauthorized and reauthorized my Mac on iTunes, no change. Turned off and on again home sharing, no change. Relaunched iTunes with a new library file, no change. Copied a DRM'd iTunes movie onto my PC, turned it into a shared library (same account, obviously), and it did gave the same authorization errors. Since I have two Apple TV's that are both doing it, I'm now starting to wonder if this is a code issue...
     
  4. Seamaster macrumors 6502a

    Seamaster

    Joined:
    Feb 24, 2003
    #4
    Apple's support forum for Apple TV has been absolutely ablaze with complaints about this for the last day or two — there's obviously something knackered at their end.
     
  5. MOFS macrumors 65816

    MOFS

    Joined:
    Feb 27, 2003
    Location:
    Durham, UK
    #5
    Tried Googling the forum but couldn't find it - do you have a link? ATM my Apple TV will play iTunes-bought music and music videos but not films. All other type of media is ok. So far I have

    • Deauthorised and then reauthorised my Mac
    • Turned off and then on Home Sharing
    • Reentered my AppleID login details
    • Reset my AppleTV

    All system software up to date, Latest iTunes etc ...
     
  6. ryan.hayes79 macrumors member

    Joined:
    Jun 27, 2008
    #6
    Same issues here but oddly I have two Apple TV 2's and one works fine. There only difference is one hasn't been powered down in weeks and the one with the issues has turned off and had no power as I turn it all off at the mains when I go to bed.

    Spoke to Apple support and they are aware of the issue.
     
  7. Onimusha370 macrumors 6502a

    Joined:
    Aug 25, 2010
    #7
    Same problem here guys, it's pretty annoying... I hope apple can fix whatever it is, maybe something to do with the next release of a new iTunes that might be coming soon? Maybe the icloud integration? Or they might be having problems related to all of the new countries now on iTunes? Just a thought.
     
  8. JezzerP macrumors newbie

    Joined:
    Apr 1, 2011
    Location:
    York, UK
    #8
    Chalk up another with the same problem....ATV2 streaming purchased content fine yesterday afternoon, not working this morning. Strangely, I can stream the same content around my other macs, iPad and iPhone, just not to the ATV.
     
  9. Seamaster macrumors 6502a

    Seamaster

    Joined:
    Feb 24, 2003
    #9
  10. MattG macrumors 68040

    MattG

    Joined:
    May 27, 2003
    Location:
    Fletcher, NC
    #10
    Having the same issue here. Glad I'm not just going crazy :)

    This is getting annoying. I spend more time trying to get this thing to work properly than I do actually using the damn thing.
     
  11. lajollabub macrumors newbie

    Joined:
    Oct 2, 2011
    #11
    Same issue here - Apple has become Microsoft

    Just started on my ATV2 in the middle of watching a program early this Sunday morning. Streaming TV and movies no longer works. Can still watch TV shows from the cloud via ATV2. Apple products are starting to cause me the same level of frustration caused by back office software changes and non-compatible hardware upgrades that Microsoft and PCs caused me when I decided to switch to Apple. I will think of the current Apple experience, one of many recently, when I go out and buy a PC and an Amazon Kindle Fire.
     
  12. jb60606, Oct 2, 2011
    Last edited: Oct 2, 2011

    jb60606 macrumors 6502a

    Joined:
    Jan 27, 2008
    Location:
    Chicago
    #12
    I just started having this problem late last night. Ruined my date. Angry. Thanks Apple :mad:
     
  13. bucksaddle macrumors 6502

    Joined:
    Dec 4, 2008
    Location:
    UK
    #13
    Until Apple fix the issue you can always "push" the content from iTunes via AirPlay. Bit of a pain having to start the media on the computer in the first place but this seems to work on all my purchased items that are currently giving me the authorization message directly from the Apple TV.

    Edit: sorry should have read the whole thread, seems this has already been mentioned.
     
  14. Mr. McMac Suspended

    Mr. McMac

    Joined:
    Dec 21, 2009
    Location:
    Far away from liberals
    #14
    got the same problem here. I get this error when trying to play content that worked a couple of days ago. What changed??

    Hold on! I had my external hard drive turned off! It works now
     

    Attached Files:

  15. Aidoneus macrumors 6502

    Joined:
    Aug 3, 2009
    #15
    Add another one to the list here. Any kind of iTunes DRM'd video content won't play. Computer is definitely authorised, and no changes have been made to any settings recently (Has been working fine for around a year).

    I would imagine it has something to do with Apple's servers being switched over to iCloud, causing some issues with the DRM polling. If the issue isn't resolved by tomorrow, I will call Apple.
     
  16. Rich1963 macrumors 6502

    Joined:
    Jul 18, 2008
    #16
    The AppleTV support site is down at www.apple.com. Am I being paranoid in thinking that Apple is shut it down until they correct the problem to 'deny' there is a problem? Seems awful convenient...
     
  17. Thorasgard macrumors newbie

    Joined:
    Mar 21, 2008
    #17
    I have had my Apple TV for just under three weeks now.
    Also having the same issue.
    Thought it was the Apple TV.
    I must have restored it about 6 times yesterday. :mad:
    Lets hope it gets fixed Pretty damned quick. :)
     
  18. JezzerP macrumors newbie

    Joined:
    Apr 1, 2011
    Location:
    York, UK
    #18
  19. StephenAcworth macrumors member

    Joined:
    Sep 19, 2011
    Location:
    Ontario, Canada
    #19
    Power off then power on

    When this happens [occasionally] i just remove the power and then replace it seconds later: hey presto, it works!:)
     
  20. IscariotJ macrumors 6502a

    Joined:
    Jan 13, 2004
    Location:
    UK
    #20
    Not this time....

    Thankfully, purchased content is a small percentage on my ATV.

    The sooner Apple get this sorted, the better.....
     
  21. viderian macrumors newbie

    Joined:
    Oct 2, 2011
    #21
    Same thing here. I have been pulling my hair out over this. This stuff shouldn't happen from Apple.
     
  22. Roach4riders macrumors newbie

    Joined:
    Oct 2, 2011
    #22
    ATV Authorization Issue

    My ATV froze up in the middle of watching purchased content and when I rebooted I am running into the same "authorization" issues. I too have another ATV which is currently working fine and is not running into any problems (at least not yet). By the sounds of the other comments I am strongly suspecting that it is something that Apple is doing with their servers.
     
  23. saving107 macrumors 603

    saving107

    Joined:
    Oct 14, 2007
    Location:
    San Jose, Ca
    #23
    I should have checked this forum first because like others, I currently have the same issue. I tried using the Purchased tab on the Apple TV directly and it tells me it can not complete my request (also, since yesterday I can not download Movie trailer from iTunes, I get the same error and to try again later)

    For the time being I have loaded the content (content purchased from iTunes) I want to watch onto my iPad and then I use AirPlay, that seems to be working.
     
  24. rotlex macrumors 6502a

    Joined:
    May 1, 2003
    Location:
    PA
    #24
    Subscribing, and adding myself to the list. Started last night. In frustration, I spent 2-3 hours trying to figure out what was wrong. Googled for the problem, and found a ton of posts on the Apple forums regarding this, and then this morning looked here as well.

    Here is hoping the issue is resolved quickly. Very frustrating. (For reference, using a 6mo old ATV2).
     
  25. Pughie macrumors newbie

    Joined:
    Oct 3, 2011
    #25
    Apple TV and DRM problems

    Been following thread for last two days as I had same problem, spent two hours re-installing software etc before thought to check if issue was more widespread doh!

    Just checked now and it looks like i can now access all purchsed TV and Movie content from iTunes store so I assume Apple have fixed the problem.
     

Share This Page