Help: Apple TV refuses any protected content ever since 5.1 update

Discussion in 'Apple TV and Home Theater' started by daneoni, Nov 6, 2012.

  1. daneoni macrumors G4


    Mar 24, 2006
    I've searched other threads and have tried most suggestions i could but no dice. So here goes. I got an Apple TV in summer and was loving it because it worked brilliantly. H

    However ever since i updated to 5.1 it has been a nightmare. NOTHING protected by HDCP plays. I rented several movies and ended up forfeiting them because it kept slapping me with the HDCP error. Also tried to stream WSJ and even Apple media event but no dice. Everytime without fail i get the HDCP error

    I've swapped cables, restarted, restored but it won't budge. It even ruined one my dates (no joke). My TV (Sony Bravia 40" LCD) is old but it works with everything i have no problem and it worked with the Apple TV Pre-iOS 5.1.

    Can anyone tell me what i'm doing wrong cos i'm about to slam this thing into a wall. All it can do now is stream Youtube and trailers.

    Can i go to an Apple store and have them downgrade the software for me or is there a way i can do it myself
  2. macman312 macrumors 6502

    Oct 10, 2010
    Melbourne, Australia --> Cincinnati,OH

    Just take it to an apple store and show them....
  3. slothrob macrumors 6502

    Jun 12, 2007
    After a relatively problem-free aTV experience, I had a problem with not being able to play any Apple content, one day. At some point I had signed out of my iTunes account on my computer. The problem went away when I signed into my account on the computer.

    That may not be your problem, but I would start by signing (out of, if necessary, then) back in to iTunes on both your computer and the aTV.

Share This Page