Help! AppleWorks keeps 'locking up' for 10secs - 3 mins

Discussion in 'Mac Apps and Mac App Store' started by Jayb, Aug 26, 2007.

  1. Jayb macrumors newbie

    Joined:
    Aug 26, 2007
    #1
    First time forum user, hoping someone can advise me why my AppleWorks prog constantly takes a few commands or lines of typing then seems to seize up and will not respond to the keyboard. This happens for anything between 10 secs and 3 mins or so. Sometimes it just slows down to a crawl, only acknowledging one letter with every flash of the cursor, regardless of how many letters, etc. have been typed in.
    When locked up it shows the little black and white rotating circle, but often after that has shown for a while it shows the coloured 'beachball' type rotating circle for a while.

    Ths problem does not affect any other programmes (eg Safari) running at the same time.



    I'm on an eMac, OSX10.4.10, running Appleworks 6.2.9.
    I'm not a computer geek, just an average home business user. Can anyone please suggest how I can stop this or where I go for help?
     
  2. Eraserhead macrumors G4

    Eraserhead

    Joined:
    Nov 3, 2005
    Location:
    UK
    #2
    I suggest moving over to iWork as Appleworks has been discontinued.
     
  3. rdowns macrumors Penryn

    rdowns

    Joined:
    Jul 11, 2003
    #3
    Try repairing permissions.

    Find the Utilities folder inside the Applications folder. Launch Disk Utility and then click the repair permissions button.

    Make sure you quit out of AppleWorks before doing this.
     
  4. Jayb thread starter macrumors newbie

    Joined:
    Aug 26, 2007
    #4
    Thanks guys!
    Tried repairing permissions, sadly that hasn't fixed it. Maybe I should just jump to iWorks, I didn't know that AppleWorks has been discontinued.
     
  5. rdowns macrumors Penryn

    rdowns

    Joined:
    Jul 11, 2003
    #5
    Try moving its plist file to the desktop and relaunching the app.
     
  6. DoFoT9 macrumors P6

    DoFoT9

    Joined:
    Jun 11, 2007
    Location:
    Singapore
    #6
    appleworks remember past documents you have opened and stuff. this often gets clogged up. simply delete them to fix the issue.

    Macintosh HD>>Users>Your User Name>Documents>AppleWorks User Data>Starting Points>>Recent Items.

    delete everything in there. it SHOULD fix it.
    if not im stumped
     

Share This Page