HELP: apps not installing. (Lion)

Discussion in 'Mac OS X Lion (10.7)' started by FreddieN, Mar 26, 2012.

  1. FreddieN macrumors newbie

    Joined:
    Oct 4, 2011
    #1
    When trying to install a program, it goes through the process as normal and when its time to install it asks to enter password. So when the password is entered, the password window disappears and continues to show the window asking to install, hit install again it does the same thing repeatedly. Nothing happens. :confused: Very frustrating.

    I read somethings on other forums about there being a password bug issue with Lion and that should reset my password and that should do the trick. WRONG.

    To answer some questions that may be asked.

    1. Yes, I am entering the password correctly. (Even reset it)

    2. It happens with every program/drivers I've been trying to install over the past few days. (This has never happened before, it's a recent issue.)

    3. My macbook is completely up to date with updates, etc.
    (I'm running 2.4 Ghz intel core duo, 4gbs ram, 500g hd)

    4. I have tried restarting, fully shutting down, etc.


    Someone please help?! :eek:
     
  2. FreddieN thread starter macrumors newbie

    Joined:
    Oct 4, 2011
    #2
    Also because of this, im not able to delete apps with app cleaner because it does nothing when i enter the password
     
  3. nawg macrumors newbie

    Joined:
    Jun 10, 2012
    #3
    Me too

    I have the exact same problem, but no solution yet, I'm afraid. Apps like MS office and Adobe Flash player will no longer update, because they use an installer that requires a password. This is very frustrating. I'll post back here if I find a solution.
     
  4. iVoid macrumors 65816

    Joined:
    Jan 9, 2007
    #4
    If you have another account with admin rights (if you don't have another, create a new one), try entering that username/password and see what happens.

    If that doesn't work, create a new admin user and login as it and try installing something.
     
  5. nawg macrumors newbie

    Joined:
    Jun 10, 2012
    #5
    Can't create another account either!

    Thank you for the suggestion, iVoid. Unfortunately, I'm still stymied...

    I tried to create a new admin account as you suggested, and the same problem blocked me here too! I went to "Users & Groups", and there's a lock icon in the lower left which is locked to prevent changes. I clicked the lock to unlock and make changes, and it prompted me for my password. I entered my password, pressed "return", and... nothing happened. Still locked, and the "+" button to add a new account is still greyed out.

    I know my password is correct, because if I enter any other password, the password dialog box shakes back and forth and does not disappear. When I enter the correct password, the dialog box disappears but nothing happens, just like when I try to update or install a program.

    Thank you in advance for any help!
     
  6. nawg macrumors newbie

    Joined:
    Jun 10, 2012
    #6
    Fixed!!

    I finally called apple support, and after one false start my problem is fixed! All I had to do is re-install the operating system... :(

    Sounds bad, maybe, but really it was not that hard, and didn't affect any of my files or settings. But it does need an internet connection and can take many hours, so best to do it overnight!

    Steps:
    1. Turn off computer
    2. Turn on computer while holding down command-R
    3. Keep command-R held down until the apple logo appears.
    It should boot into recovery mode and give you several options
    4. Select "Reinstall Mac OS X"
    5. Follow the instructions and it should reboot on its own. I was downgraded to the previous version of Lion (10.7.3), so I had to run apple software update to upgrade again to 10.7.4.

    And viola, my administrator authentication works again! I can install programs, create new user accounts, etc. I'm quite pleased that apple support actually solved my problem.
     

Share This Page