Help! Blinking Finder... Stranded in Peru

Discussion in 'Mac Basics and Help' started by chloejagger, Sep 24, 2008.

  1. chloejagger macrumors newbie

    Joined:
    Sep 22, 2008
    #1
    Please help me! I am currently coordinating a volunteer construction project in the northern slums of Lima, Peru and my computer is an absolute must to ensure both the continuation of this project and my emotional stability. Before I indulge you with my computer crisis let me emphasize that I can be considered computer handicapped... I am one of those people who purchased an ibook G4 circa 2005 purely based on user friendliness and asthetics.

    Last week as I was trying to configure my computer to the local internet connection, I attempted to unlock my settings. It would not however, let me enter my password regardless of how many attempts I made to unlock them. I therefore decided it would be best to restart my computer. When I restarted my computer it would flash the grey screen with the apple and then without asking me which user to login as (although there is only one) it would go immediately to my desktop where Finder seems to be crashing and consequently reopening, crashing, reopening, the result of which is a flashing desktop where all my documents and applications sit there taunting me for hours at a time without me not even being able to access ANY of them. Everytime I try to access an application it immediately crashes and returns to my flashing finder.

    Needless to say, Ive tried everything from restarting my computer to begging it to come back to life... If anyone has ANY solutions (explained in vivid detail) for me I would be eternally grateful. Ive searched the forums already but cant seem to find anything that will help given that I cannot open anything from my desktop.

    Thanks!
     
  2. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #2
    Since you obviously cannot launch any applications nor even use the Finder, the first thing I would try is a Safe Boot. To do this, hold down the Shift key after the computer turns on and makes that "bong" sound. If that makes it work, the most likely cause is an application or kernel extension incompatible with your version of Mac OS X.

    Assuming that is the case, the way to track down the culprit is to look at your system log files. This can be done with the Console application, in your Utilities folder (which is inside the Applications folder). There will probably be a bunch of entries related to Finder crashing. You'll also see references to file names where the crash logs were stored - the next thing to do is find these logs, and open one of them up. This will reveal details of the crash, which can help pinpoint exactly where the problem lies.
     
  3. chloejagger thread starter macrumors newbie

    Joined:
    Sep 22, 2008
    #3
    This cant be good

    First and foremost thank you so much for responding!!

    I did exactly what you said in terms of holding down the shift key to boot in safe mode. When I got the little window asking me for my password I entered it and for a second I thought everything was going to be fine because a window popped up reminding me to change my date and time but then it logged out of my desktop and brought me back to the password window... I entered it again and it logged me in for a second and then back out again...again.. and again.

    Any other ideas we could try... Ill even take this thing apart if you tell me to.

    Thanks
     
  4. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #4
    This sounds like an odd issue with your settings for logging out after a period of inactivity. It's almost as if it somehow got set to 0 minutes, which would explain the behavior you're seeing.

    Fixing this is going to require a little bit of UNIX. If you're unfamiliar with the command-line, just make sure you type the commands given exactly as written. First of all, you're going to want to boot your computer into what's known as Single-User Mode. To do this, hold down Command (also known as the Apple key - on some keyboards this has the Apple logo on it) and S simultaneously, just after the computer powers on and makes that bong noise.

    This will take you to a command prompt. Here, you can type various commands to diagnose problems with your system. This page contains some common commands you'll be using - read through it.

    The first thing you'll want to do is make the boot drive writable, so you can change things. To do that:
    Code:
    mount -uw /
    If it was successful you'll get no feedback, just a new command prompt.
    Secondly, check the file system for errors:
    Code:
    fsck -y
    If it says FILE SYSTEM WAS MODIFIED, run it again until it doesn't.
    Third, try rebooting normally, and see if the problem is fixed. To do that:
    Code:
    reboot
    Remember to press Return after entering each command to execute it.
     
  5. chloejagger thread starter macrumors newbie

    Joined:
    Sep 22, 2008
    #5
    No luck.

    I even tried running the -f option so that it would force check my computer. The result came up as The Volume Microsoft HD appears to be OK. When I log into safe mode again the same thing happens. Basically, it looks like the same thing that is happening is regular mode is happening in safe mode only its asking me for my password first.

    I hope this doesnt mean I have to start looking up computer recycling plants in Lima...
     
  6. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #6
    That didn't work, so the next thing to try is nuking the preference file that stores the automatic log out setting. This happens to be here:
    Code:
    /Library/Preferences/.GlobalPreferences.plist
    If you're still unable to do this while logged in normally, you'll have to go into single user mode again. The command you need for this is rm - be VERY careful. There's no undo for removing the wrong file with the rm command.

    Code:
    rm /Library/Preferences/.GlobalPreferences.plist
    That's the command you need.
     

Share This Page