HELP! Bottom half of lockscreen is black!

tesilential

macrumors regular
Original poster
May 9, 2010
224
0


Last night, and today.


Does anyone know the path and file to something in openSSH that I can change to fix this?

Deleted winterboard which did nothing. Every lockscreen wallpaper is like this now.
 

tesilential

macrumors regular
Original poster
May 9, 2010
224
0
Does anyone know which file I screwed up and need to change? I'm new to SSH

I don't wanna restore just based on this!

If anyone has any help at all please post, even if its just a link to somewhere I can find out how to locate this file!

thanks!
 

hoogen

macrumors regular
Jun 22, 2010
167
30
what else do you have installed on the phone. i am confused on how you deleted winterboard and the nexus wallpaper is still there. more info on the situation would help, did you add/change anything the night before this happened? and have you done a hard reset? (holding power and home button untill phone turns off, then turn phone back on)
 

tesilential

macrumors regular
Original poster
May 9, 2010
224
0
what else do you have installed on the phone. i am confused on how you deleted winterboard and the nexus wallpaper is still there. more info on the situation would help, did you add/change anything the night before this happened? and have you done a hard reset? (holding power and home button untill phone turns off, then turn phone back on)

Those screenshots are from before I deleted Winterboard. the first one was to show my sister my cool lockscreen. The second one was taken after the problem emerged.

I deleted Winterboard right before posting this thread, as a last resort, but it didn't help.


I had LockInfo a couple days ago, deleted it, then reinstalled last night.



EDIT: Also, Springboard has crashed for me several times, mostly while pressing the "lock" button rapidly. It usually just resprings and is fine, but last night
Also I downloaded a few themes for winterboard, including the Simpsons theme, thats when I noticed the issue.

I also added a few Cydia sources, which turned out faulty, and now give me Errors in Cydia
 

hoogen

macrumors regular
Jun 22, 2010
167
30
could it possibly be that the unlock slider is turned off in lockinfo and because the wallpaper you had was a video one it caused it to glitch. go into settings>lockinfo>lockscreen>layout>hide lock slider. just a thought. also, does lockinfo work for you? you could have an old version that isnt supported on ios4, that has caused springboard to crash multiple times
 

tesilential

macrumors regular
Original poster
May 9, 2010
224
0
crap, I just remembered, last night I downloaded "WeatherIcon" from david.ashman.com in cydia. (This and "LockInfo" are the only 2 apps in this source)


Well after the download, I resprung, then my phone totally crashed. It froze on the lock screen where I could see the status bar, but the wall paper was black and I was stuck on that screen for several minutes.

I then did a hard reset ("lock" + "home" buttons) and the phone reset again, but then got stuck on the black lockscreen again.


I plugged my phone to the laptop, using the USB cable, then I open WinSCP and attempted to connect to the phone via openSSH. The connection failed, so I hit "retry" and the phone vibrated, then the phone turned on (I closed out of WinSCP on the computer).

I went into Cydia and deleted "WeatherIcon" which was what I believe caused the crash, and rebooted. The phone worked fine, but it was sometime after that when I noticed the screwed up Lockscreen.
 

tesilential

macrumors regular
Original poster
May 9, 2010
224
0
UPDATE: Seconds after that last post, I deleted LockInfo through Cydia.

This fixed the lockscreen. I like LockInfo so I will attempt to get it working properly.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.