help - browser keeps stopping!

Discussion in 'macOS' started by im-loving-it, Jan 20, 2013.

  1. im-loving-it macrumors member

    Joined:
    May 3, 2010
    #1
    I just got a macbook pro off ebay a few weeks ago and everytime i use the internet the page doesnt load after about 10-15mins, even youtube is slow as hell.

    it was fine on my pc when i had it but for some reason on this mac its slow and pages stop loading and its annoying cuz the only way to stop it is i have to close ALL my tabs on my browser and load up safari again.

    things i tried already:

    1. downloaded google chrome and its the same story, havent tried firefox yet.
    2. i changed my internet connection from wifi to the netwok cable, the wifi was strong signal cuz the laptop is in same room as router.

    anyone know what else i can try?

    macbook pro 2008, snow leopard, 200gb hard drive by the way.
     
  2. simsaladimbamba

    Joined:
    Nov 28, 2010
    Location:
    located
    #2
    Does it also happen in another, even temporarily created, user account?

    When you bought the Mac, was there a fresh install of Mac OS X 10.6 Snow Leopard on it?
     
  3. im-loving-it thread starter macrumors member

    Joined:
    May 3, 2010
    #3
    thanks for replying, when i got it LEOPARD was on it so i bought a SNOW LEOPARD disc cuz i heard its better and installed that on it.

    and as for user account - i only got 1 user on it cuz im the only person using it, u think its the browser? or it might be some internet settings?

    when i download the torrents on uTorrent its fine speed no problem, just when browsing the internet and youtube is slow as hell
     

Share This Page