Help: Calling all Mac geniuses...

Discussion in 'Macintosh Computers' started by, Jul 12, 2004.

  1. macrumors member

    Jun 23, 2003
    Toronto, Canada
    Here's the challenge: Due to problems to be described below, AppleCare told me to reinstall (archive & install) panther as last solution before sending in unit for repair. I'd like to find out if there's any other way of going about this....are you smarter than Applecare? I hope so...

    System: eMac 1.25Ghz / direct connection to cable modem (Rogers--Canada), no router / 10.3.4

    Description of Events:
    Went home this weekend to to say hi to the folks. They just picked up a new eMac couple of months back after years of hounding from both my brother and I--two dedicated Mac lovers. Everything was going well until Sunday when my mom complained that the Internet didn't work. After close inspection (sys prefs), and a quick renewal of DHCP lease, I noticed that the Internet connection would stay active for roughly 30-60 seconds before disappearing.

    But here's the weird thing: I still had an ip address! Sys prefs thought everything was fine--still showed connection to the cable modem--but the Internet (any forms of web connection) was essentially frozen waiting for a reboot (renewal) of DHCP lease.
    1. Called ISP support. After some slight mods, still no fix. Tested cable modem on old Pentium system--worked without cutting out (5 min test). So it's not the cable modem and it's not a router cuz I don't have one. ISP suggested perhaps its a firewall issue but that makes no sense as my folks have had the Panther firewall on for months and this problem only started Sunday.
    2. Called AppleCare. Explained the situation and the guy proceeded to help me reset all hardware prefs. I reset: PRAM, Open Firmware, even dragged the Library's System Preferences folder out to the desktop so that upon reboot it would recreate the folder. Nothin'...same cutting out after 45 seconds.
    3. So I'm left here (after a desperate 10.3.4 combo update install which I prayed would fix everything but of course didn't) with one option as described by AppleCare: to archive and install Panther again and hope everything works out. I really don't want to do this...not because I'd lose documents (I can back those up), but rather because there's no guarantee it'll work and it would be a huge waste of time to reinstall all the apps. It's pretty annoying, you must admit--especially when my folks bought this machine they wouldn't have to do any reformatting a la Windows once they got the eMac.

    *As outlined in my challenge above, I'm looking for people that can outwit AppleCare and figure out what the problem is. It's like something on the computer is telling my Mac to stop talking with cable modem but to keep the ip. Can anyone think of any conceivable software or system setting that would tell the Mac to do this. Any work arounds (continuous ip renewal?)? D'you think the archive and install would do anything? And if I send the eMac to Apple would the hard drive get erased (for instance if they replaced a defective ethernet card)?

    :(Basically, as you can tell, I'm stumped. Any help is appreciated. I'll be around to answer further questions, if any.

    Thanks guys and gals...
  2. Horrortaxi macrumors 68020


    Jul 6, 2003
    Los Angeles
    I'm at least as good as AppleCare, but you've just about covered everything. I was going to tell you to look for preferences related to networking or ethernet and trash them, but you've already done that apparently. When you say you trashed a bunch of preferences, were they from the user folder, the Library folder at root level, or both? If it was at the user level, do the systemwide ones.

    You've repaired permissions? Run the cron jobs? Repaired prebindings? That's all just voodoo but it can't hurt--but also probably won't help--except for permissions.

    Any funny little apps running? Things that have access to the bowels of the OS?

    I'd say you're at the point where you should reinstall (archive and install). Just for the record, I never say that. I always try to talk people out of reinstalling because they do it for stupid reasons. This isn't one of those cases. This is a funny little software problem and if you dig deep enough you'll probably find the cause--but it's lots quicker and easier just to reinstall. It's not a big ordeal to do it.
  3. Thom_Edwards macrumors regular

    Apr 11, 2003

    someone correct me if i'm wrong, as i've never done this, but i think archive and install means you do *not* have to reinstall your apps/docs. if that is the case, i would take their advice.

    however, just my $.02, my guess is that it is not a software issue. i know you said you still have an ip address and such, but blaming software for this doesn't seem to add up. you mentioned you have a pc--get a crossover cable and try to ping the mac from the pc and vice versa. i'm gonna guess it's a nic card going bad.
  4. Mord macrumors G4


    Aug 24, 2003
    just archive and install all it dose is replace the system folder and back up all your stuff when you boot again everything will be in place just like it should it only takes 20 mins so just do it
  5. garybUK Guest


    Jun 3, 2002
    Try setting your network card's speed manually to 10mbps, i had a dodgy ntl cable modem that didn't like apple's auto speed thingie.... once set, try rebooting, if not it does sould like the network card could be going bad.
  6. zarquon macrumors newbie


    Jul 13, 2004
    If you are using File Vault, turn it off. File vault causes some strange interactions with other parts of the OS and could be the cause of this problem. On my system, File Vault would reset the prefs for my Bluetooth, and it would turn on and be discoverable when I didn't want it to be!

  7. frenetic macrumors regular

    Feb 11, 2004
    As Hector said, an archive and install won't make you reinstall your apps, it just replaces the system folder (and unix system), so no need to worry, it's a 20 minutes thing.
  8. thread starter macrumors member

    Jun 23, 2003
    Toronto, Canada

    Funny, the AppleCare guy said that I WOULD have to reinstall apps (not docs and prefs though)..he said to archive and install back without retaining network prefs.

    I too believe it is probably a faulty NIC card. But if it was faulty, wouldn't my ip be lost when I lose connection? It's still there, so the card seems to be working, no?

    What kinda of little apps would tinker with Internet settings? (FYI, the net settings I trashed earlier were in the system folder, not user)
  9. jimsowden macrumors 68000


    Sep 6, 2003
    System preferences can remember IPs even though the connection isn't current. Go into terminal and type "ping" and if it send back the packages then go ahead with the archive and install. If it doesn't, i would say you have a bum ethernet port.
  10. mowogg macrumors 6502


    Mar 10, 2004
    San Gabriel, CA
    User Issue?

    Have you tried creating a new user and connecting under that log-in? Some times that solves these kind of problems. That being said, I think it's a hardware issue related to the ethernet card. If you can get your hands on one, you could try an USB to ethernet adapter and see if you have the same issue through that connection. That's a pretty expensive option as I doubt you could return it after the test, but it is a way of testing the hardware/software.

    Best of luck.
  11. millar876 macrumors 6502a


    May 13, 2004
    Kilmarnock, Scotland UK
    similar problem

    I had a similar (well the exact same actualy) problem, same symptoms, same lack of good info from applecare, but it turned uot that my problem was due to the fact i had the same instalation of panther (from same 3 cds) on 2 difrent macs (networked through airport) shairing the DSL connection on my eMac with the powerbook. what seemed to be happening is that because the instalations were the same, when the iBook requested packets from the internet, the software base station on the emac became confused and didnt forward the information to the right mac. hope this helps
  12. thatwendigo macrumors 6502a


    Nov 17, 2003
    Sum, Ergo Sum.
    Do a few things for me before I weigh in, if you don't mind.

    You can find the necessary applications in HD > Applications > Utilities:
    1. Open Network Utility and System Profiler. Using the default pane that's open in Network Utility and the Network pane in System Profiler, check the Hardware Adress and make sure they match. In Network Utility, look to the right and see if the packets sent and received are mostly going through, rather than being dropped.
    2. Try a few pings and traceroutes from Network Utility, just to see if your machine is somehow confused by the routing at your ISP. I have no idea how this could affect only one machine, but it's worth checking, even if your ISP and the PC seem to talk to each other. At worst, it shows that your machine is to blame.
    3. Check Activity Monitor for any suspicious processes that might be lingering in the system, perhaps as part of a poorly written third party application. Kill them. Also, check the startup items (HD > Library > StartuItems) and log (HD > Library > Logs) folders for odd parts that might have been scattered. I once had a serious issue with drivers for a third party keyboard that didn't function quite right.
    4. As a last ditch measure, check the Network panel in system preferences and be sure that the ethernet port is both default and checked in the pulldown menu 'Show,' under the item ' Network Port Configurations.' I'm not even sure the system would let you try to connect without it, but I'm thinking of every possible minor point that might be wrong.
  13. thread starter macrumors member

    Jun 23, 2003
    Toronto, Canada
    status: still nothing

    1. Everything matches in terms of ethernet addresses labeled en0...I don't know what fw0 means, btw
      ping and traceroute of returned nothing -- could not find address
    check and check...I have no third party things or little haxies...just microsoft office (it's my parents machine, remember...old people can't handle complex compter stuff, at least not mine :rolleyes: )

    So as it stands, it seems like its a hardware issue because it can't even ping, right? But then why is it that everytime I renew dhcp (or even wake from sleep), Internet still works for a min then shuts off...doesn't make sense. Could an archive and install actually do anything, or is it a waster (realistically this problem happened not after performing any tasks, rather after 5 days without using the computer--sleep)

    Any ideas? Thanks so much for the help so far. Hopefully a couple of more posts can do the trick!:)

Share This Page