Help! Cannot get iPad Device ID to register w/ Dev account

Discussion in 'iPad' started by jhkaplan, Jun 6, 2011.

  1. jhkaplan macrumors regular

    Jan 29, 2008
    I was an idiot and installed the ios 5 beta on my ipad 2, before registering my Ipad2 w/ our dev account. The install went fine, until it came time for activation. I get the error:

    We're unable to complete your activation. This device is not registered as a part of the Iphone Devleoper Program.

    I know where to go in the iOS dev center to register the device, however both my iPad and iPad section of iTunes shows this message, so I have no way of getting the UDID to put it in the dev center? I'm handcuffed!! I need the device ID to activate iOS 5, but I cannot access it from iTunes or the iPad.

    Does anyone know of another way to access the device ID to register my ipad w/ the Dev center?

    Thanks for your help!

  2. MacFan23 macrumors 6502

    Feb 17, 2010
    Have you tried registering it as a developer device in Xcode?
  3. 3goldens macrumors 68000


    Feb 26, 2008
  4. jbazar macrumors newbie

    Oct 23, 2005
    under a rock
    I have an iPad2 Wifi 32GB that is registered w/ Dev account and device is stuck in setup too. I can choose the wireless but can not go any further. When i connect it to the Desktop running iTunes it says that this device is not a registered device. What is going on? I registered the iPad 24 hours ago.
  5. Adam1989 macrumors newbie

    Jun 5, 2011
    Download the "iphone config utility" and get the udid from their.
  6. pcxpress macrumors newbie

    Jun 7, 2011
    i have the same error.
    First installed the iOS5 on my iPhone 4 and after that i registered it on my Dev-Account.
    How many Time needs it, to be active in the Acc?
    I need my iPhone every day... stupid :(
  7. sd87 macrumors newbie

    Jun 7, 2011
    Hey, I also registered my device and still won't work!

    Anyone know away around this? I just signed up as a developer, do I have to do anything else other than register my device for it to work?
  8. pcxpress macrumors newbie

    Jun 7, 2011
    ok the new ios5 didnt work for me, but i was able to downgrade on 4.3.3

    Put your iDev in RecoveryMode and restore it with the original 4.3.3, thats it.
  9. JustinJ macrumors newbie

    Aug 14, 2009

    Go to Apple Menu > About this Mac > More Info > USB

    You'll see you iPad in the list of devices if it's plugged in. The Serial Number is your Device ID.

    -- Justin
  10. JadeDaugherty macrumors newbie

    Aug 10, 2011
  11. jijotomy macrumors newbie

    Aug 19, 2011
    Fixed! Really?

    I'm confused. How is the serial number and Device ID (UDID) related? The only ID I could get from Justin's post is the serial number which is accessible on the iPad itself. It's printed on the back side of the iPad and it's also listed in the Settings>>About page on the iPad.

    I was under the impression that the original poster was looking for the Device ID (40 digit Hexadecimal) rather than the serial# (12 alphanumeric characters). Or is there a way to get the device id if you know the serial#?

Share This Page