Help! Cannot SSH Into Phone

Discussion in 'Jailbreaks and iOS Hacks' started by cristovao, Apr 25, 2011.

  1. cristovao macrumors 6502a

    cristovao

    Joined:
    Aug 20, 2010
    Location:
    Calgary
    #1
    Hey guys, hopefully someone will be able to help. First, here's what I've got:

    • iPhone 4
    • 4.3.1 jb via PwnageTool
    • Winterboard
    • SBSettings
    • iFile
    • Mobile Substrate
    • Mobile Terminal
    • Open SSH

    I've used WinSCP on my Windows 7 machine at work and Ducky on my MacBook Pro at home. I used Mobile Terminal to change my root password. No matter what, I cannot connect to my iP4 and view/change files and directories. The SSH toggle in SBSettings is set to ON but I don't see it on the main SBSettings screen.

    Anyone have any thoughts? Let me know what other info you may need.
     
  2. h1r0ll3r macrumors 68040

    h1r0ll3r

    Joined:
    Dec 28, 2009
    Location:
    Maryland
    #2
    I think you also need to download afc2add in Cydia as well.
     
  3. cristovao thread starter macrumors 6502a

    cristovao

    Joined:
    Aug 20, 2010
    Location:
    Calgary
    #3
    Thanks! That didn't help me wirelessly connect but I installed iPhoneBrowser and I'm in! Finally!

    Thanks so much!
     
  4. hackthatphone macrumors 68000

    hackthatphone

    Joined:
    Jul 28, 2010
    #4
    I've used openssh for years on the iphone and haven't installed afc2add.

    It works just fine. I use a real ssh client like yummyftp or fugu so I can change permissions if needed. Most of those other programs out there like diskaid can't do this.
     
  5. cristovao thread starter macrumors 6502a

    cristovao

    Joined:
    Aug 20, 2010
    Location:
    Calgary
    #5
    Although I'm working now using iPhoneBrowser, what can you see from my setup above that would prevent me from connecting wirelessly using openSSH and WinSCP or CyberDuck?
     
  6. Prodo123 macrumors 68020

    Prodo123

    Joined:
    Nov 18, 2010
    #6
    Misspelling of passwords during change of root password?
    You should reset your password to alpine and change it again. Make sure you remember what you typed, and type carefully.
    Also, afc2add is less secure because it doesn't require a password. You're better off using SSH, just in case.
     
  7. jarjartee macrumors newbie

    Joined:
    Jun 12, 2011
    #7
    Give this a shot !!

    Just reposting something that happened to me, it was poopooed by a member of this forum, nevertheless it worked for me !!


    Had big problems connecting with cyberduck on iphone 4. Tried any configuration under the sun, so downloaded Fugu, turned WPA security off and hey presto I'm in !! (iPhone4 - Greenpois0n 4.3.2) , used port 22

    OK here's the deal folks, turn of all security on router, connect Cyberduck/Fugu (both in turn if you've got them) - bookmark connection and Quit. Put security back on router - all works brilliantly . I have now tried this 3 times; computer on/off etc-seems to stick ;)
     

Share This Page