Help! Can't boot...from anything!

Discussion in 'MacBook' started by doowrehs, Apr 13, 2008.

  1. doowrehs macrumors regular

    Oct 14, 2004
    Well, I think I've just experienced a HD failure with my MacBook 2.16 rev c. (April 2007). The drive is actually a 200gb Hitachi TravelStar 7,200rpm model which I installed about 6 months ago to replace the stock drive. Anyway, I used the MacBook this morning and all was fine, then returned to it this afternoon and it was completely frozen. Did a hard reset and tried booting, but all I got was fans powering up to the max followed by the question mark folder. Tried again, but now the drive just clicks away ominously and I continue to get the question mark.

    This is not a huge problem, as I've backed up most of the stuff on the drive. However, I now find that I can't boot from anything in order to use Disk Utility and check that the disk is indeed fried. I've tried booting from the original install disks that came with the MacBook, with a Leopard disk, and with my DiskWarrior disk (the newest version) - all of which just get spat out after a minute or so. And just to clarify: on startup, I've tried holding down 'C' or holding down 'option' to search for boot directories whilst using these disks. But nothing happens. I'm fairly sure there is no problem with my superdrive as I used it in the morning with no problems.

    So, any ideas what's happening here? It's my understanding that I should be able to boot from an install disk, etc. regardless of the state of the HD. Am I missing something? By not being able to boot from these disks does it suggest that the problem goes beyond the clicking HD? I'd really like to use Disk Utility to make sure the drive is actually dead before I purchase another one.

    Any help very gratefully received!
  2. motulist macrumors 601


    Dec 2, 2003
    If you can't startup from the installer disk by holding down the C button, then you may be in worse shape than just a busted hard disk. Try starting up from the installer disc that came with your Mac (not a retail version of the OS X stand alone installer) while holding down the option key, which'll start you up in the hard disk diagnostic mode. Then tell us what the result of that test utility was.
  3. Sun Baked macrumors G5

    Sun Baked

    May 19, 2002
    If Apple is still bootstrapping these Intel machines by looking for a file on the HD, then a corrupted drive could still lock out booting from the DVD.

    Don't know how quick the EFI machines look for the files on the boot volume, could still be before a keypress like the PPC machines were.
  4. doowrehs thread starter macrumors regular

    Oct 14, 2004
    Thanks Motulist and Sun Baked for the replies. Unfortunately, I've already tried booting from the install disks that came with the MacBook as well as attempting to run the Hardware Test that's on the second disk, but neither way works. All I get is the superdrive spinning up for a minute or so (sounding completely normal i.e. no frantic head-motor noise as if trying to read a damaged disk), and then the disk gets spat out shortly after. If I hold down option on boot, I get the pointer arrow on screen - but that's it. No startup manager interface, nothing.

    This is just strange, and I really hope that it's not a sign that the logic board has died also.

    Sun Baked - if you have time, I'd really appreciate it if you could explain what you mean a little more. Are you saying that Intel machines can't boot from CD/DVD disks the way PPC Macs can?
  5. motulist macrumors 601


    Dec 2, 2003
    Okay, first off, don't panic. Don't turn a small problem into a big problem by doing anything hasty.

    Here's a thought, after correctly grounding yourself to prevent a static electricity disaster, try to reseat all your ram chips making sure they are very firmly in their slots (which usually takes more pressure than you would expect).

    I imagine it's possible that a RAM problem could prevent any type of boot.

    If you're technically proficient you might wanna do the same thing with your hard drive's connections.
  6. MacHappytjg macrumors 65816

    Mar 24, 2008
    first off try hitting option when starting up and if theres nothing then u know cause i dont know but i think theres somthing wrong with my 60gb cause it didnt show anything when putting in option

Share This Page