Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.


macrumors 6502
Original poster
Jun 10, 2006

Happens both when i have something plugged into the headphone jack, and when i don't. Restarting did not seem to help.



macrumors 601
Mar 20, 2005
I would first try zapping the PRAM and resetting the NVRAM. That usually fixes problems like these when I get them.


macrumors newbie
Mar 25, 2009
i have the same problem, but when i reset the pram and nvram i still get the blocked volume icon. what else can i do?


macrumors 6502a
Jan 26, 2008
i have the same problem, but when i reset the pram and nvram i still get the blocked volume icon. what else can i do?

Do two tests:
1) Look in your headphone jack and check to see if there is a red light.
2) Check the sound system preference panel and see if sound is being output to "digital out" instead of "internal speakers."

If the answer to both is yes, then the computer is trying to output to the jack because it thinks there is something there (hence the red light). This is a decently documented problem (both here and on google). The problem tends to recur when you put something in the jack and take it out, but the computer doesn't realize that you've removed the peripheral. The solution either involves sending the thing back to Apple or poking around the headphone jack until you flip the detector and turn the red light off.


macrumors 68020
Oct 14, 2008
that is what happened to me. I took it to apple lol. it was really weird though. great info


macrumors newbie
Apr 12, 2010
Bradford, UK
Lol I was having this problem today for about half an hour I was troubleshooting it and trying to solve the problem. I saw this thread and it said check for a red light near the headphone place and then guess what...?

My headphones weren't plugged in properly lolz.

Also I realize I bumped up an old topic lol.

Thanks guys. :D

brudda saami

macrumors newbie
Jun 18, 2013
same problem

hi i have the same problem with my macbook air, except I don't have any red light, the headphone thing didn't work and resetting the PRAM didn't work either. Happened about 2 weeks ago but then it was fine after a week and now once again after about a week it has started doing the exact same thing. I looked at the system preferences and checked my output device but none are showing. There are no output devices available and I cannot seem to install one.
Can anyone help?
One love


macrumors newbie
Jun 6, 2016
I HAD the same problem but I figured out what I did wrong. Before you get all excited, this may not work because my situation was different. I recently downloaded a recording software where it had its own volume thing.. So, it kinda installed into my MacBook and I didn't know, but then I tried controlling my volume but, it was stuck on full blast, couldn't do anything 'bout it. But, what I did was go to System Preferences and clicked on sound, then I clicked output and noticed that it was selected onto the other volume thing, so then I chose the Internal Speakers, which are Built-in and then yeah, it worked again!

I hope this could help you a bit, at least.:oops::apple:


macrumors 6502a
Jul 8, 2012
Sometimes this can happen if you are connected to an external display via DisplayPort. The Mac will sometimes try to send audio out over the DisplayPort to the monitor.
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.