help, can't connect to itunes musicstore; "keychain invalid"

Discussion in 'Mac Basics and Help' started by cowgirl, Nov 17, 2006.

  1. cowgirl macrumors newbie

    Nov 17, 2006
    hi everyone,

    i'm having a problem connecting to the itunes music store. i'm getting the message:

    "iTunes could not connect to the music store. The requested keychain is invaild. Open Keychain Acess and run Keychain First Aid then try again"

    i've used the itunes store before (quite often), but suddenly i'm not able to do it. i did remove my laptop from home and re-connect to my wi-fi, but i'm not sure that's the problem.

    in any case, i saw that someone else had the same problem and people suggested he do various things (drag the keychains folder to the desktop, type in the password, reboot...remove the "plist" files...). i tried all that and it didn't work. eventually the man fixed his problem by repairing corrupt files, but i don't know how to do that.

    any ideas? i miss my itunes shows!

  2. Counterfit macrumors G3


    Aug 20, 2003
    sitting on your shoulder
    Have you tried running the Kychain First Aid?
  3. cowgirl thread starter macrumors newbie

    Nov 17, 2006

    yup, a bunch of times, but it didn't work :(

    or i guess i should say that it says there is no problem
  4. Westside guy macrumors 603

    Westside guy

    Oct 15, 2003
    The soggy side of the Pacific NW
    I had a similar (but not exactly matching problem) - this would only be applicable if you use a different keychain password than your login password.

    Recently Apple added a keychain preference "Synchronize login keychain password" and, stupidly, enabled it by default. Part of the issue here is it doesn't work very well, so in some cases you have to type in your login password and in other cases your old, different keychain password. Half the time my keychain wouldn't work; and a few times I got that same "invalid" message.

    The other part of that issue is they added this feature without really letting us know. :D So suddenly I found myself having constant keychain problems for no apparent reason, other than upgrading to 10.4.8.

    In this particular situation, the solution was to uncheck that "synchronize" box, run keychain first aid, and then change the keychain password to something different (and then change it back to what you really want it to be). I haven't had a problem since.
  5. sclink macrumors newbie

    Jan 27, 2009
    here's another solution

    In Keychain Access, go to Window > select Keychain List
    Select theLogin keychain and then select the "Global" box at top right, then hit Apply
    You may also need to do this for the system keychain.... worked for me
    (this fixes the keychain invalid original problem in this thread)


Share This Page