Help! Can't delete Yosemite partition

Discussion in 'OS X Yosemite (10.10)' started by Am3r1ca16, Jul 17, 2014.

  1. Am3r1ca16 macrumors 6502a

    Am3r1ca16

    Joined:
    Jul 17, 2012
    Location:
    New York City
    #1
    I'm trying to delete the yosemite partition but everything is greyed out. and for some reason now i have yosemite partition twice?

    anyone know how i can delete the partition?

    thanks!
     

    Attached Files:

  2. onceyougozak macrumors newbie

    Joined:
    Jul 17, 2014
    #2
    Try this

    I've recently run into this problem with an external drive. Have you tried formatting the Yosemite partition first? I think Disk Utility sees that there are system-level files on the drive and lock any changes "for your protection."

    Once I formatted the Yosemite partition and restarted my computer, Disk Utility gave me the option to delete it. Go figure!
     
  3. tywebb13 macrumors 68020

    Joined:
    Apr 21, 2012
    #3
    No. You don't have the partition twice. What has happened is that the yosemite installer created logical volume groups. You can run this in terminal to get your partitions back to normal. You will then be able to change them again.

    diskutil cs list

    and then

    diskutil coreStorage revert lvUUID

    where lvUUID is the last lvUUID reported by the previous Terminal command.
     
  4. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #4
    A Yosemite install to a second partition like that turns it into a core storage volume, and that is why it looks odd in DU. You can delete it following this.
     
  5. Am3r1ca16 thread starter macrumors 6502a

    Am3r1ca16

    Joined:
    Jul 17, 2012
    Location:
    New York City
    #5
    Oh I fixed it a few minutes after posting this.

    All I did was boot my computer while holding comm+R and when I was in disk utility I clicked on the Yosemite partition and I had to first delete the partition then it renamed it self back to HD. And then I was able to make it one partition again

    Sorry I suck at explaining
     
  6. chrisrand macrumors member

    Joined:
    Aug 17, 2013
    #6
    Easy fix


    I know this is an old article, but this recently happened to me and the easiest way to get rid of the Yosemite partition is to:

    1) Boot your other OS, mine was Mavericks
    2) Open Disk Utility
    3) Select the Yosemite partition
    4) Select the erase tab, erase it,
    5) Select the main drive and go to the partition tab, where you can then delete the Yosemite partition and resize it back to the original size.

    Hope that helps!
     
  7. theodecker macrumors newbie

    Joined:
    Oct 1, 2014
    #7
    Hello,

    I had the same problem like the OP and followed theses steps from 3 posts above:

    After this I actually was able to resize the partitions again, however, now I am stuck with "lost disk space" as you can see in my screenshot:

    The "Macintosh HD" partition has been resized to a smaller size, but I am not able to make the space available to the "Yosemite" partition.

    Any solution other than deleting Yosemite?

    Thanks!
     

    Attached Files:

  8. theodecker macrumors newbie

    Joined:
    Oct 1, 2014
    #8
    OK, I solved it by:

    - Creating a third partition from the "lost" or inaccessible space that I had between the two partitions

    - The I restored Yosemite to the newly created partition using Disk Utility

    - Then I deleted the last partition in the list

    - And finally I expanded the disk space of the partition I had created in the first step
     

Share This Page