Help, can't eject osx cd on powerbook, cant start up...

Discussion in 'PowerPC Macs' started by wendylloyd, Aug 12, 2009.

  1. wendylloyd macrumors newbie

    Joined:
    Aug 12, 2009
    #1
    Hi all, please help if you can. I bought a powerbook off ebay, it worked but on startup occasionally a folder icon would appear. I rebooted from the original discs which seemed to do the trick. However the original discs are too old for many of my apps, so I bought some newer install discs (osx 10.5) I put the install disk in and got the panic message 'panic: Im hanging here'
    The answer seems to be to run a disk repair (am i right?) However to do that I need to eject the install disc, I can't get the install disk out and of course it keeps tripping up everytime I start it. There is no secret little button to eject the disk manually. I have tried holding down apple and S but the install disk over rides everything and trips the mac up. I think ill be okay if I can just get this disk out! Vicious circle...
    Wendy
     
  2. flatfoot macrumors 65816

    Joined:
    Aug 11, 2009
    #2
    This should work to get the CD/DVD out:

    After starting up the PowerBook, immediately press and hold the alt/option key on your keyboard.
    It may take while until it comes up showing you your available boot drives, including the CD/DVD.

    Now release the alt/option key and press the eject-button on your keyboard.
    If this doesn't work right away, click the CD/DVD's icon first, then press the eject button.

    This worked for me on my Mac Pro a few weeks ago.
     
  3. donuttakedonuts macrumors regular

    Joined:
    Aug 9, 2009
    #3
    if i were you i might replace the hd, sounds like a bad drive. The pb drive replacement is wicked easy compared to, say, an ibook. Not as easy as a 2008 mbp though... sorry.
     
  4. MWPULSE macrumors 6502a

    MWPULSE

    Joined:
    Dec 27, 2008
    Location:
    London
    #4
    Further to that suggestion by flatfoot you can try using the mouse button, that ejects CDs on boot up:)

    PTP
     
  5. dmmcintyre3 macrumors 68020

    Joined:
    Mar 4, 2007
    #5
    If all else fails

    CMD-OPTION-O-F on boot

    Then at the prompt type

    eject cd

    If that makes the cd come out type:

    reset-all

    to reboot.

    This is for PPC Macs only as far as I know(G3 G4)
     
  6. donuttakedonuts macrumors regular

    Joined:
    Aug 9, 2009
    #6
    Finally my g4 ibook beats something in some category! :D
     
  7. chan2004 macrumors regular

    Joined:
    Oct 7, 2007
    Location:
    India, currently Zurich,Switzerland
    #7
    I have encountered a similar situation in my MB

    Insert a business card into the drive. Place it below the disk and push up.
    Then, press the eject button.
    If it still doesn't work, tilt it 45 degrees, do the above operation again and press the eject button again

    I hope this can be done in your PB too
     

Share This Page