help! can't eject windows install disk

Discussion in 'MacBook' started by keepnpeace, Jan 17, 2011.

  1. keepnpeace, Jan 17, 2011
    Last edited: Jan 17, 2011

    keepnpeace macrumors newbie

    Jan 17, 2011
    I partitioned in bootcamp and then started to install Windows but got an error at the selection of drive to install since I forgot to format the partition to NTFS. Getting error that can't install Windows to FAT.

    Now I can't eject the windows disk and I'm stuck in an install loop that I can't get out of.

    Can't get any reboot options, eject key doesn't work and can't get back to Mac OS.

    If I power down it just boots up to the Windows disk.

    I'm a noobie on Mac so be gentle.

    I have MacBook and can't tell you much more than that since I can't get to OS to see system info.
  2. QuarterSwede macrumors G3


    Oct 1, 2005
    Colorado Springs, CO
    Power on the Mac and hold down the eject key till it ejects. If it boots into the installer then hard reboot (hold down power). Then press power and immediately hold option down till you get to the boot loader. Once that comes up hold eject and it should pop out.

    My father had a problem yesterday where nothing (even the terminal command "drutil tray eject") would eject it. Getting it to boot to the boot loader and ejecting that way is the only thing that worked.
  3. keepnpeace thread starter macrumors newbie

    Jan 17, 2011
    Thank You!

    That worked...phew I was getting very frustrated. Now back to what I was originally trying to do! :eek:

Share This Page