Help! - Can't Install Mavericks on SSD RAID 0

Discussion in 'OS X Mavericks (10.9)' started by maxwell5050, May 16, 2014.

  1. maxwell5050 macrumors newbie

    Joined:
    Apr 22, 2014
    #1
    I have been trying for 2 days now to install Mavericks on my Mac Mini with 2 Samsung Pro 512 SSD's in a RAID 0 and it just won't work (Apple software has really been disappointing me lately).

    I've installed OS X on RAID 0 in the past without a hitch so I tried the same process.

    Plan A

    First I made a bootable Carbon Copy clone of my functional Mavericks installation to an external drive. When I tried to boot from it wouldn't work and would go straight into OS X Utilities! After many attempts I gave up and went to plan B

    Plan B

    I made a Time Machine backup on the external drive and booted from it. I then used Disk Utility from Recovery Mode and created a RAID 0 from the 2 internal SSD's. I then attempted to restore from the Time Machine backup and was presented the following error "An error occurred while adding a recovery system to the destination disk".

    Apparently, OS X can't add recovery partitions to a striped RAID (anymore?) and it refuses to restore without creating the recovery partition!

    Plan C

    I downloaded Mavericks from Mac App Store and created a install disk on my external drive and booted from it. I then attempted to create a clean install of Mavericks on my striped RAID. The installation process was going fine until it reached "about a minute left" where it froze.

    I read many similar posts saying it will reboot after 15 minutes. Over an hour later it was still stuck so I canceled the install and tried again.

    On the second attempt, it did the exact same thing and I waited over 3 hours and it was still stuck on "about a minute left". So, I did what others suggested and forcefully powered down the machine. On booting it did not recognize the RAID as being bootable and the installation process was unsuccessful.

    So, with one last effort I performed the install again and this time I let it sit on "about a minute left" overnight (for 8 hours) and when I woke it, up was STILL stuck!!

    Really Apple? Your OS can't even be installed on a striped RAID anymore????

    Has anyone been able to get this to work ??
     
  2. h9826790 macrumors 604

    h9826790

    Joined:
    Apr 3, 2014
    Location:
    Hong Kong
    #2
    Not sure about Mac min, but lots of Mac Pro user have their Mavericks on SSD RAID 0. It should be very straight forward if both SSD is directly connected to the SATA port.
     
  3. Kasalic macrumors regular

    Joined:
    Jan 20, 2011
  4. maxwell5050 thread starter macrumors newbie

    Joined:
    Apr 22, 2014
    #4
    Just an update....

    I found that the problem was with Mavericks 10.9.2 which refused to install on a RAID 0.

    I tried with Mavericks 10.9.3 and it worked fine.

    However, I still can't get Carbon Copy to create a bootable drive with Mavericks. It always goes into Recovery Mode. It's the latest version of CCC that supposedly supports Mavericks but it just doesn't work.

    I've seen this problem posted on their forums but their support staff just gave a baffled response.
     
  5. Bruno09 macrumors 68020

    Joined:
    Aug 24, 2013
    Location:
    Far from here
    #5
    It does work fine on Mavericks, NO problem (for me).
     
  6. maxwell5050 thread starter macrumors newbie

    Joined:
    Apr 22, 2014
    #6
    What version of Mavericks do you have?

    I've tried over a dozen times and it just continuously goes into Recovery Mode and will not boot from the cloned drive.

    I'm using Mavericks 10.9.3 and CCC 3.5.4
     
  7. Bruno09 macrumors 68020

    Joined:
    Aug 24, 2013
    Location:
    Far from here
    #7
    I have used CCC on many Macs, on Mavericks 10.9, 10.9.2 and now 10.9.3.

    Just done 2 bootable clones of Mav 10.9.3 today, without any issue.

    (I use CCC 3.5.4 for the first clone, then 3.4.7 to update the clone)

    Are you sure your external hard drive has a GUID partition scheme ?
    (if not the clone is not bootable).
     
  8. maxwell5050 thread starter macrumors newbie

    Joined:
    Apr 22, 2014
    #8
    Yes, I've formatted the drive each time prior to cloning with a single GUID partition in OS X Journaled.

    I've gotten CCC to work in the past many times but despite over a dozen attempts not a single on has worked with Mavericks.

    The files are on the drive but it's not bootable and goes straight to recovery if I attempt to boot from it.

    I've even tried with different hard drives and get the exact same result.

    No idea what the problem is but it's highly disappointing as I have been having to use Time Machine which is not a very reliable backup.

    I guess I'll have to use rsync to get a bootable drive.
     
  9. Bruno09 macrumors 68020

    Joined:
    Aug 24, 2013
    Location:
    Far from here
    #9
    Can't understand what the problem is.

    I use CCC almost every day on various Macs from 10.5 to 10.9.3 with no problem.
    (to make bootable clones as backup).

    :(
     

Share This Page