HELP! Can't open apple file security protected files

Discussion in 'Mac Apps and Mac App Store' started by macgrrrl, Jul 30, 2006.

  1. macgrrrl macrumors newbie

    Jul 30, 2006

    ok here's my dilemma. i used to use OS 9 Classic with the Apple File Security feature. i used it to password protect a lot of different files. eventually i upgraded from OS 9 Classic to OS X (Panther) with the option to run OS 9 if i needed to. i wanted to keep using Apple File Security (AFS) so i would open OS 9, open AFS, and then password protect the files of my choice.

    well, just recently, i tried to open a file that i password protected, and it wouldn't prompt me for the password. instead, a Convert File From box popped up with choices like, "Text Only, MS-DOS Text, Rich Text Format (RTF), HTML Document" etc. this never happened before. usually when i click on the file i want to open, OS 9 will automatically start up and then i will get a prompt to type in the password for the file. not this time. if i choose one of the options in the Convert File From box, it opens up the file with a bunch of jibberish.

    what's changed? why am i being asked to convert the file when all i want to do is open it?:confused:

    i've tried opening it by manually opening OS 9 first and then the file but the same thing happens. i haven't done anything different. i recently downloaded the macairportfix for my aol but other than that or the usual mac updates, i haven't changed anything.

    i am having this problem with only one AFS protected file. all the others works fine.

    one weird thing i noticed was there's an AFS protected file called "tEmP*cRyPtFiLe-10002" in my folder. i don't know where this file came from and when i try to open it, it asks for a password which i do not know. could this be the root of my problem?

    can anyone help me? i really need to get this file open. thank you from the bottom of my apple-shaped heart.
  2. Nermal Moderator


    Staff Member

    Dec 7, 2002
    New Zealand
    What type of file is it? I suspect that one of your apps (looks like a word processor or similar) has "grabbed" the association for that file type (ie. the word processor is opening it instead of the decrypter). Does it look like that's happening?
  3. macgrrrl thread starter macrumors newbie

    Jul 30, 2006
    thanks for your reply. yes, you are right. it is using the MS Word to open it instead of Apple File Security (AFS). but i tried changing it to open with AFS and it continuously asks for me to enter the password or create a new one.
    any thoughts?

Share This Page