Help! Can't open Mail app after upgrading to ML.

Discussion in 'OS X Mountain Lion (10.8)' started by HXGuy, Aug 24, 2012.

  1. HXGuy macrumors 68000

    Joined:
    Mar 25, 2010
    #1
    I am freaking out over here!

    I upgraded to Mountain Lion and everything seems to work ok except the Mail app. When I try to open it, I get this error:

    [​IMG]

    I have my Mail folder on an external hard drive, not on the boot drive, and this worked fine in Lion. Permissions are fine, even though the error says they are not. I tried to reset them, did the Command+R and the resetting permissions and ACL from there.

    Did a bunch of searching online and found on link that said alias no longer work in ML and you have to do syslinks so I tried messing with that and somehow deleted the whole Mail folder, all 44GB of it! Luckily I have a clone backup (though I probably lost all the mail from today?) and I have a Time Machine backup as well. Right now I'm waiting while it copies over the Mail folder from the cloned backup onto the external drive again.

    What a mess. :(
     
  2. HXGuy thread starter macrumors 68000

    Joined:
    Mar 25, 2010
    #2
    Wow, can't believe I got everything working again, that was nuts.

    Found this post here that was very helpful: http://forums.macrumors.com/showthread.php?t=1411289

    My other drive was named "Storage Drive" and for some reason Terminal wasn't liking the space in there, and it kept not working. I got the idea to change the name of the drive to just "Storage" and once I did that, it setup a symlink right again and everything was up and running. Of course the cloned copy of the Mail data wasn't up to date, but luckily I also have a Time Machine backup so I was able to grab the file from just before the ML update and everything is all good now.
     

Share This Page