Help! Cant restore after jailbreak

Discussion in 'iPhone Tips, Help and Troubleshooting' started by evidence3, Jan 18, 2010.

  1. evidence3 macrumors newbie

    Joined:
    Jan 18, 2010
    #1
    I tired to jailbreak my iphone 3gs today.

    I downloaded black ra1n..... then i ran snow,rock, and cydia....
    then i tired to tether it. I followed this page: http://www.mobilecrunch.com/2009/11...ther-on-an-iphone-3g-or-3gs-running-os-3-1-2/

    I couldnt get it to tether so i was going to restore it....

    but Itunes wouldnt pick up the phone. I tired the forced reset, put it in recovery mode but nothing worked.

    in recovery mode, Itunes recognized the iphone and tried to restore it, but it never finished and kept saying "unknown error occurred (1604)"

    now when i restart it just black or says on the screen with the itunes usb picture.


    I dont know what to do, help.
     
  2. jtmx29 macrumors regular

    jtmx29

    Joined:
    Jan 14, 2010
    Location:
    Connecticut
    #2
    Your PC should pick up the IPOD and allow for reformat via iTunes. You might want to try it on another PC?
     
  3. evidence3 thread starter macrumors newbie

    Joined:
    Jan 18, 2010
    #3
    tired another pc....tired another usb cord too

    uninstalling and reinstalling itunes right now
     
  4. NathanA macrumors 6502a

    Joined:
    Feb 9, 2008
    #4
    If you are trying to restore official Apple firmware to a device that has been jailbroken, you need to put the phone into DFU mode first.

    If you make yourself a custom, already-patched 3.1.2 IPSW file with PwnageTool, you should be able to restore that without needing to go to DFU mode.

    -- Nathan
     
  5. evidence3 thread starter macrumors newbie

    Joined:
    Jan 18, 2010
    #5
    I did the DFU thing....still got the error.....each time i reboot it, it goes to the itunes/usb pic.... the only time it changes is if i run black rain again, it loads up with the pic of the guy and the iphones....then restart back to the itunes/usb pic
     
  6. evidence3 thread starter macrumors newbie

    Joined:
    Jan 18, 2010
    #6
    i tired ireb....that didnt work.....

    but i finally got it to work. No idea how, but this is what made it work:

    Try the following, which worked for someone else:

    Disconnected all other USB items (ext. hard drives)
    Disabled Symantec Anti Virus
    Reset the iPhone to get the screen with the lead pointing to iTunes (Hold down lock button on top)
    Plug iPhone in when this image of Lead/iTunes showing
    Start iTunes
    iTunes recognised iPhone in Recovery mode, offered to restore
    Clicked Restore, it unpacked then tried to run
    iPhone flashed then went to black screen, eventually iTunes gave the dreaded 1604 error.
    I then unplugged iPhone, but instead of resetting it again (which I've tried about 20 times already), I left it with black screen (although black, screen is definately on as not totally pitch black).
    Shut down iTunes
    Plugged phone back in (Still with black screen)
    Started iTunes, again noticed recovery mode, pressed Recover
    The black screen then popped in to life and had a small recovery icon at the bottom in the middle and the restore worked perfectly!!!



    got that from here: http://discussions.apple.com/message.jspa?messageID=6445113

    incase anyone else has this issuse
     

Share This Page