Help Compiling Eterm

Discussion in 'Mac Apps and Mac App Store' started by joshuwa72, Dec 27, 2003.

  1. joshuwa72 macrumors member

    Nov 4, 2003
    Chelsea, Michigan
    I want to compile and run Eterm (under X11) so I can run borderless terminal windows (and I like Eterm better).

    when doing './configure' I get this:
    Rawk-Box:~/Desktop/Eterm-0.9 joshua$ ./configure
    loading cache ./config.cache
    checking for a BSD compatible install... (cached) /usr/bin/install -c
    checking whether build environment is sane... yes
    checking whether make sets ${MAKE}... (cached) yes
    checking for working aclocal... found
    checking for working autoconf... found
    checking for working automake... found
    checking for working autoheader... found
    checking for working makeinfo... found
    checking for egcs... no
    checking for pgcc... no
    checking for gcc... (cached) gcc
    checking whether the C compiler (gcc -O ) works... yes
    checking whether the C compiler (gcc -O ) is a cross-compiler... no
    checking whether we are using GNU C... (cached) yes
    checking whether gcc accepts -g... (cached) yes
    checking how to run the C preprocessor... (cached) gcc -E
    checking for AIX... no
    checking for POSIXized ISC... no
    checking for minix/config.h... (cached) no
    checking for Cygwin environment... (cached) no
    checking host system type... configure: error: can not guess host type; you must specify one
    I know I need to run configure with the argument
    but I dont know what darwin version I am running.

    I am using OS X Panther 10.3.2 (clean install of panther + upgrades).

    any help would be appreciated, thanks everyone!
  2. bousozoku Moderator emeritus

    Jun 25, 2002
    Gone but not forgotten.
    System Profiler will tell you under Software:

    Attached Files:

  3. joshuwa72 thread starter macrumors member

    Nov 4, 2003
    Chelsea, Michigan
    I looked there before I posted (I guess I should have specified - I appologize).

    I then tried
    and I get an error saying
    'Darwin 7.2.0 not recognized'
    or something similar to that.

    I sure do wish compiling on a mac was easer - I tried the fink thing but that caused more problems then I wished to have.

    Thanks again!
  4. Doctor Q Administrator

    Doctor Q

    Staff Member

    Sep 19, 2002
    Los Angeles
    You could try grepping through some of the source directories looking for "darwin". Maybe you'll find a list of known darwin version strings, e.g., powerpc-apple-darwin_7_2.
  5. Westside guy macrumors 603

    Westside guy

    Oct 15, 2003
    The soggy side of the Pacific NW
    Hmm... eterm 0.9.2 installed just fine for me under fink unstable. I know that's not what you're using, but perhaps you could take a look at what fink is doing in their package.
  6. joshuwa72 thread starter macrumors member

    Nov 4, 2003
    Chelsea, Michigan
    Are you using panther??

    I tried installing fink on 10.3.2 and it gave me a lot of problems and I couldn't get it to work.

    I've heard the makers of fink had some issues w/ panther and advise its use w/ caution...:confused:

    I dont know - all I want is to be able to install Eterm so I can run border-less windows and I cant seem to be able to install anything I need to compile because of
    bash:configure: could not guess host; host not recognized
    If it wasnt for iChat/iTunes/Photoshop/Mail I'd just run full-blown linux.

Share This Page