Help connecting iMac and 2 MIDI over ip devices

Discussion in 'Mac OS X Server, Xserve, and Networking' started by wod8o5, Apr 16, 2018.

  1. wod8o5 macrumors newbie

    wod8o5

    Joined:
    Apr 16, 2018
    #1
    Hello all, I have searched and searched and searched all over the internet to try and solve my issue and I still cannot find a resolution. I have resorted to see if their is any expert on here that could possibly help solve or guide me in the right direction.

    I have a 2017 iMac running High Sierra. I also have a Solid State Logic Nucleus 2 (DAW Controller) and a Solid State Logic Sigma. Those two devices are used in conjunction with Logic Pro for music product. They both communicate via midi over IP or the use of ipMidi driver. My studio is on the second floor of the house and so to get the network up there, I purchased a Orbi RBS40 satellite. I then connect my iMac and two SSL devices into that router. Both of the manuals for the Solid State Logic products tell me to set the devices to use DHCP for the network setup and they will all work fine and communicate with each other. Well that is not the case and I am at a loss of what to do to fix it. I am wondering if I have to do something in network routes or modify a setting in the router. The manuals for both devices say to turn off airport because it will interfere with the two devices trying to talk to the computer/application.

    I am not a network engineer so ill try and explain this the best I can. Do I have setup something up somewhere that tells the network/computer what connection is what? I guess what I am trying to say is: Do you/can you configure the network to say this is the internet and it goes down this road and these ipMidi devices go down this road and separate them so they don't interfere with one another. I hope that made sense. I can quote what the manuals say but its pretty brief outside of setting the device to DHCP and thats about it.

    Does anyone understand or think they know what might going on here?

    Also I will move this to another forum if this isn't the appropriate one.
     
  2. bookemdano macrumors 65816

    Joined:
    Jul 29, 2011
    #2
    I'll take a stab at this. It's hard to know exactly the problem without seeing how everything is configured, but I think I can at least help you make progress.

    1. You mentioned you have an Orbi RBS40 satellite. I assume then that you also have an Orbi router (the RBR40 or RBR50 or one of their devices with RBR in the model name)? I think that's required unless you're hardwiring the satellite to your existing router. If you're trying to wirelessly connect the satellite to your router then you need an Orbi router in addition to the Orbi satellite. You didn't mention if you did or not so I'm just making sure.

    2. Assuming you do have an Orbi router and the satellite is talking to it, then anything you plug into the ethernet ports on the satellite should connect into the same network same as if they were directly plugged into your router. You can easily test if that is working by plugging your iMac via ethernet into the Orbi satellite and then turn off WiFi on your iMac (click on the WiFi icon in the menu bar by the clock and choose "Turn Wi-Fi off"). With the iMac connected via ethernet and Wi-Fi off, you should be able to go to your web browser, download email, bring up google, etc. If that works then the Orbi setup is working fine and is not the problem. Conversely, if the internet isn't working when connected via ethernet with Wi-Fi off then the Orbi satellite isn't talking to the Orbi router.

    3. Assuming that you are connected to the internet with Wi-Fi off as instructed above, and your Solid State Logic devices are also connected to the satellite via ethernet and they are powered on, their driver software running on your Mac should be able to locate them. If not then I would contact them and see what they suggest troubleshooting-wise. If they are set up to get a DHCP address then your router would be assigning them one (nearly every router is configured to do that by default--disabling DHCP would require an overt effort).

    If you're wiring the iMac into the Orbi satellite then you don't really need WiFi to be connected on the Mac, because that's just giving your Mac two different connections to the same network. I think that normally Macs are set up to "prefer" their Wi-Fi connection over the ethernet jack. You can adjust that by going to System Preferences, choosing "Network", then click the little cog wheel icon at the bottom left and choose "Set Service Order". Then you can drag ethernet so it's listed before Wi-Fi (or just double check that it's already listed first).

    Hopefully something in there will help. If not, reply back with the results and we'll go from there.
     

Share This Page