Help connecting my iMac and Dell laptop

Discussion in 'Mac OS X Server, Xserve, and Networking' started by AWShuttleworth, Sep 29, 2008.

  1. AWShuttleworth macrumors newbie

    Joined:
    Jul 1, 2007
    #1
    Here's my problem -- it's driving me crazy. I'll be very grateful for any help I can get.

    I've got a new home network set up using a D-LINK wireless router. I've got my Dell laptop running Windows XP and my iMac running Mac OS X 10.5 both connected to the wireless network.

    I have an instance of Windows Server 2003 running in VMware Player on the Dell. VMware Player is networked in bridge mode, meaning that the D-LINK has assigned the VMware Player OS its own IP address as if it were a separate machine.

    Using the host OS on my Dell (Windows XP), I can navigate to the website hosted by the guest OS, by entering the guest OS's IP address into Firefox. I can also navigate to the web pages in the Sites folder of my Mac by entering the Mac's IP address into Firefox on the Dell.

    But I can't access the VMware site from my Mac.

    Shouldn't I be able to? What am I doing wrong? And do you guys see what I'm trying to do here?

    FWIW, the firewall is turned off on the Dell computer.
     
  2. belvdr macrumors 601

    Joined:
    Aug 15, 2005
    #2
    Can you ping the virtual IP, and just to be sure, is the virtual IP on the same subnet as the iMac?
     
  3. AWShuttleworth thread starter macrumors newbie

    Joined:
    Jul 1, 2007
    #3
    Yep, I can ping it from the Dell and from the iMac both. I'm not sure how to check if it's on the same subnet. Where would I check on that? Both the iMac and the virtual have IP addresses in the form of 192.168.0.XXX, if that's what you mean.
     
  4. belvdr macrumors 601

    Joined:
    Aug 15, 2005
    #4
    So, you can ping it, so the network connection is good and they are on the same subnet.

    If you open Terminal, try this:

    Code:
    telnet <IP of VM> 80
    then hit enter several times. Does it clear the screen and drop the connection or just sit there without doing anything?
     
  5. AWShuttleworth thread starter macrumors newbie

    Joined:
    Jul 1, 2007
    #5
    Thanks for the help. That terminal command just sits there doing nothing, saying after a little while, "Operation timed out."

    One other thing I've tried, if this is of interest -- I set my wireless router to forward all port 80 requests to the virtual IP, and then I used the network's external IP to try to access it over the Internet -- nothing. As a control, I also tried forwarding port 80 requests to my iMac, and that worked fine.

    Thoughts?
     
  6. AWShuttleworth thread starter macrumors newbie

    Joined:
    Jul 1, 2007
    #6
    I just realized that I can't access the Windows XP web server either -- the one on the host OS. Both the host and guest OS on the Dell can get to those pages.
     
  7. myjay610 macrumors regular

    Joined:
    Jan 6, 2008
    #7
    Are we sure about the firewall issue? If you can ping the XP box and the Server box from the Mac but you can't reach them over port 80 it sounds like a firewall issue to me. Are there any firewall/port forwarding options in the VM software? Do you have a third-party anti-virus (norton, etc) running on the Dell that might have a firewall on?
     
  8. AWShuttleworth thread starter macrumors newbie

    Joined:
    Jul 1, 2007
    #8
    It's certainly possible. The Dell belongs to my employer, a large enterprise, so it's possible that there's a hidden firewall. There's nothing that's visible to me, though -- a look through the running process list doesn't reveal any obvious culprits.

    Anyway, if it is that, perhaps I shouldn't turn it off anyway. For the moment, I've copied the Virtual OS off of the laptop and onto the iMac, so I can run it in VMware Fusion and access it that way. It's not ideal, but it'll do.
     

Share This Page