[HELP] Console errors regarding ATSServer and Quicklook

Discussion in 'macOS' started by cookieme, Jun 5, 2009.

  1. cookieme macrumors regular

    Joined:
    Aug 22, 2005
    #1
    Hi

    I'm running 10.5.7 on my MacBook Air and while browsing the Console System Messages I came across the following lines which seem odd.



    I have tried to understand what is going on and validated all my fonts using FontBook with no errors. I have not installed any fonts apart from those that come with the system and iWork 09.

    I presume that these messages should not happen as they are errors and must be the result of something being wrong, right?

    Thanks
     
  2. cookieme thread starter macrumors regular

    Joined:
    Aug 22, 2005
    #2
    UPDATE:

    I searched and found that there is a very easy way to remove the font caches in Leopard (ONLY). The command is atsutil, because ATSServer is Apple Type Services and is responsible for as the name suggests fonts. There are a few commands (see man atsutil), but to remove font cache for the active user only:

    Code:
    sudo atsutil databases -removeUser
    If you want to remove active user and system font cache:

    Code:
    sudo atsutil databases -remove
    
    You should restart your Mac after doing this so that they can be recreated. Of course you could have done this with Cocktail or similar, but I'm getting quite interested in learning what is going on beneath the surface and if you look at the command which Cocktail uses to perform the same action, it does not utilise the new atsutil command, but simply:

    Code:
    rm -rf /private/var/folders/*/*/-Caches-/com.apple.ATS/
    However, this unfortunately has not removed the error messages shown above!!

    Ok it's not a permissions problem because I eliminated that early on. ATSServer might be corrupted, so in my attempt to determine its state I ran an md5 checksum and compared it to another Mac running 10.5.7 and they match. I presume this is enough to rule out corruption since the other Mac does not show this error in the Console, right?

    Ok, I'm sure the error is a result of something trivial gone wrong because checking the Console further I can see that the first time it appears is Wednesday this week early in the morning (first boot of the day). This must mean that the something happened on Tuesday one day earlier. I have searched for modified and created files on this day and at the moment I'm trying to see if some file is the cause of the error.

    ANYONE?
     

Share This Page