Help: Contacts in iMessage showing up as a number...

Discussion in 'iOS 5 and earlier' started by kmark55, Oct 13, 2011.

  1. kmark55 macrumors newbie

    Joined:
    Mar 6, 2011
    #1
    My contacts show up fine everywhere, but when I open up a conversation with my friends that have iMessage, it only shows their number. Why is this happening?
    [​IMG]

    Uploaded with ImageShack.us

    ----------

    please respond
     
  2. HazyCloud macrumors 68030

    HazyCloud

    Joined:
    Jun 30, 2010
    #2
    They've set their caller ID on iMessage to their phone number. Nothing you can do on your end.
     
  3. F123D macrumors 68040

    F123D

    Joined:
    Sep 16, 2008
    Location:
    Del Mar, CA
    #3
    Under settings > Messages > Receive At

    You can add your email address for your Apple ID

    And right under that, select "Caller ID" and use your email address if you don't want the number showing up.
     
  4. black743 macrumors 6502

    Joined:
    Dec 27, 2010
    Location:
    Huntington, WV
    #4
    My friend and I are showing up with our names....so why is it different for us?
     
  5. kmark55 thread starter macrumors newbie

    Joined:
    Mar 6, 2011
    #5
    I figured it out. I logged out of my apple ID in the iMessage settings, then rebooted my phone. Are you guys able to stay logged in with your apple ID and still see your contacts as their name and not as their number?
     

Share This Page