HELP! Could not load Keyboard & Mouse preference pane.

Discussion in 'macOS' started by dsaunders, Feb 7, 2008.

  1. dsaunders macrumors newbie

    Joined:
    Jan 17, 2007
    #1
    I'm getting a bizarre error when try to load my keyboard preferences in system preferences:

    "Could not load Keyboard & Mouse preference pane."

    The function buttons on my keyboard aren't working now, and I can't seem to find a way to fix it. I'm guessing that either (1) somehow the keyboard preference pane has become corrupted, or (2) there's an application that is interfering with the keyboard preference pane.

    I'm running a recent macbook 2.16 white with leopard.

    Is anyone else seen this problem? I have only seen a mention of it on the apple forums, but no solutions or discussion on it.

    And could someone who is running leopard please email me their Keyboard.prefPane file? I'd like to replace mine and see what happens - my email address is danielsau {at} gmail dot com.

    THANKS!

    Dan
     
  2. richard.mac macrumors 603

    richard.mac

    Joined:
    Feb 2, 2007
    Location:
    51.50024, -0.12662
    #2
    hi

    first try repairing permissions in disk util, deleting the system preferences plist file in home/Library/Preferences, clearing you caches in home/Library/Cache or booting into safe mode by holding shift at startup.

    if these dont work ill post a download link of the preference pane.
     
  3. dsaunders thread starter macrumors newbie

    Joined:
    Jan 17, 2007
    #3
    Thanks very much for the help - but unfortunately none of it solved the problem.

    I think that I have a bigger issue at stake, since I noticed that I also can't load the security system preference either - I'm hoping that replacing the keyboard one might solve it, but if not, I'll probably do a clean install of leopard and start over.

    Would you mind posting the link to the keyboard pref pane or email it over to me?

    Thanks

    Dan
     
  4. richard.mac macrumors 603

    richard.mac

    Joined:
    Feb 2, 2007
    Location:
    51.50024, -0.12662
    #4
    hi,

    file hosting websites wont accept the .prefpane file extension and its too big to upload as an attachment on MacRumors. can you please PM me your email? thanks.

    if this doesnt work ill suggest resinstalling Leopard.
     
  5. dsaunders thread starter macrumors newbie

    Joined:
    Jan 17, 2007
    #5
    Just sent you a PM - thanks so much for helping!

    Dan
     
  6. relytdavid macrumors newbie

    Joined:
    Mar 24, 2008
    #7

    Hi, I have the same problem as that Dan guy. If you could send me the link that fixed his problem that would be greatly appreciated.

    email is tyler.d.fournier@wmich.edu

    thanks
     
  7. kmeleanthony macrumors newbie

    Joined:
    Jun 1, 2008
    #8
    Same problem...

    Also having the same issue, if you would be so kind - i would appreciate you forwarding it to me as well.

    thanks!

    kmeleanthony@gmail.com
     
  8. applefan69 macrumors 6502a

    applefan69

    Joined:
    Oct 9, 2007
    Location:
    Medicine Hat
    #9
    hmm several people are havin this problem? are you all using 10.5.3?
     
  9. dgdosen macrumors 65816

    dgdosen

    Joined:
    Dec 13, 2003
    Location:
    Seattle
    #10
    Just can't help it...

    "Wait! Wait! ... Cancel that, I guess it says 'helf.'"
     
  10. saudiduck macrumors newbie

    Joined:
    Jun 2, 2008
    #11
    Having the same problem.....

    My Prefpane for the mouse and keyboard wont work and like the rest I am running 10.5.3 if you could forward that email with the prefpane attached you would be greatly appreciated, thanks.
     
  11. richard.mac macrumors 603

    richard.mac

    Joined:
    Feb 2, 2007
    Location:
    51.50024, -0.12662
    #12
    i havent updated to 10.5.3 yet so maybe someone else can email it to you guys.
     
  12. vakol macrumors newbie

    Joined:
    Jul 29, 2008
  13. nuel8 macrumors newbie

    Joined:
    Oct 11, 2008
    #14
    Help!

    Hi,

    I'm having the same problem, after updating the security update 2008-007. I can't even restore the volume control and time in my menu bar. Can you also send the link to my e-mail? My email is nuel_ph@yahoo.com

    Thanks!!
     
  14. alphaod macrumors Core

    alphaod

    Joined:
    Feb 9, 2008
    Location:
    NYC
    #15
    Had the problem; performed an Archive and Install preserving user settings.
     
  15. rinju macrumors newbie

    Joined:
    Jul 29, 2015
    Location:
    india
    #16
    My Prefpane for the mouse and keyboard wont work and like the rest I am running 10.10.4 if you could forward that email with the prefpane attached you would be greatly appreciated, thanks.
    rinju.v@gmail.com
     

Share This Page