Help! cpu kernal task problem on rMBP - even after clean install!

Discussion in 'MacBook Pro' started by robertfrancis70, Nov 10, 2012.

  1. robertfrancis70 macrumors newbie

    Nov 10, 2012
    Hi everyone,

    In 20 years as a mac user, I've never seen anything like this. Beginning a week ago, after I upgraded from 10.8 to 10.8.2, my retina 15" MBP from July has been taken over completely by continuous cpu overloads (with fans blarring) caused by a kernal task that takes from 600 to 650% of my CPU's activity. The seizure can last anywhere from two minutes to 10 (after which I give up and restart). Often on restart, it immediately resumes. When a siezure occurs, the fans are blarring and computer slows to a crawl.

    I never had the problem before 10.8.2, and I think it's a software rather than hardware issue (for reasons that will be clear below).

    Here's what I've done:

    safeboot (still happens)
    reset PRAM and SMC (still happens)
    apple hardware test -- both the long and short versions (all clear)

    I also did a clean install back to Lion. During the process of the install the seizure would be occurring, often at length.

    Ran it for a few hours in Lion, problem recurred constantly (and I never experienced it in the three or four weeks I ran Lion back when I bought the computer this summer).

    I then plugged my rMBP into another mac in target disk mode and erased my rMBP's hard drive and tried Lion again. Problem returned. I then upgraded to Mountain Lion. Problem returned (with a vengeance).

    So, the best explanation I have come across for why people (with MBP's or otherwise) have been experiencing the continuous "kernel task" CPU slow down is the one offered by Rhys Oxenham here:

    In short, Rhys suggests that after Lion, OS X was set up to launch a kernel task -- whenever certain conditions are triggered (which he assumes to be temperature related) -- which ties up the CPU and thus momentarily prevents other, more demanding activities from taking place. It's a temperature control mechanism but quite invasive. The precisely conditions that trigger each computer are set out in a file contained in the system library's extensions folder (see his page for details). His solution is to delete the profile that corresponds to your model. A number of responders to his blog express elation that it works.

    Here's the problem, though. There are profiles for 50 models of Mac in that folder, but the one profile that is missing is the one for the retina MBP.

    So, what in the world do MBP retina users do?

    I'm inclined to think this is a software problem given all the tests I've done. But I'm inclined to doubt this conclusion given the fact that after wiping my drive and reinstalling Lion, the problem resumed with Lion.

    Could it be that 10.8.2 included some kind of firmware update that lodged a bug deep enough that it remains whatever system I happen to re-install, or whether I erase the drive?

    Whatever it is, is anyone experiencing the same problem and do you have any ideas?

    Thanks so much!
  2. jas07 macrumors regular


    Oct 13, 2011
    Whilst this is isnt going to be any use to you I just wanted to say thanks for that link, ive been searching for a fix for this for ages!
  3. Casteiron macrumors newbie

    Nov 24, 2012
    While I also don't have a solution for you, I want to thank you for that link!!!

    For your problem though, did you try moving the entire ktext file with all of the plists in it to somewhere else, just to see if it works?

    What's the model identifier for yours? Maybe you can search the system for a plist file with the model identifier.
  4. AirThis macrumors 6502a

    Mar 6, 2012
    This used to happen quite frequently with my Mini but it became much less frequent after I removed both Flash and Perian from that machine.

    So far I've never encountered the problem with my rMBP in 10.8.2 (been running that OS for about 6 weeks). Even if I run 3 VMs, encode with handbrake, and browse around in YouTube, the kernel_task CPU usage remains very low at all times (5-6% typical). This remains constant no matter what I do (a rise in temp does not seem to produce the issue in my case).

Share This Page