Help!!! Deleting a partition.

Discussion in 'iMac' started by SundayDuffer, Jul 9, 2011.

  1. SundayDuffer macrumors 6502

    SundayDuffer

    Joined:
    Jun 25, 2011
    #1
    Main osx 10.6.8
    Partitioned osx 10.7 just to mess around with Lion OS (everything went smooth).

    Now that i'm done with messing around with Lion OS. I want to remove the Lion OS partition. In disk utility (under 10.6.8 boot), i have highlighted the Lion OS partition and clicked the (-) sign. Disk Utility does its thing and came back with an error. (Partition failed: This operation requires a newer version of Mac OS X for this disc). I do have the latest osx 10.6.8. I have tried this twice, failed. Rebooted and tried again..still failed.

    What gives? Can anyone help me? Thx.
     
  2. simsaladimbamba

    Joined:
    Nov 28, 2010
    Location:
    located
    #2
    Have you tried formatting it first via the ERASE tab and then tried to delete to partition yet?
     
  3. SundayDuffer, Jul 9, 2011
    Last edited: Jul 9, 2011

    SundayDuffer thread starter macrumors 6502

    SundayDuffer

    Joined:
    Jun 25, 2011
    #3
    Lion OS was formated un Mac OS Extended (Journaled).
    Data has been erased. The partition is now empty. But i cant get rid of it.

    I just reformatted the LionOS partition to Mac OS Extended. Then went back to partition and delete it. Failed.
    Tried it again with Mac OS Extended Journaled. Same thing. Failed.

    Hmmmmmm.....
     
  4. SundayDuffer thread starter macrumors 6502

    SundayDuffer

    Joined:
    Jun 25, 2011
    #4
    Just read up on this issue.

    You need to boot with Lion OS in order to delete the partition.
    That means i have to create an external Lion OS, then use that to boot up, at that time i can now go in the hard drive and delete that internal partition.

    Oh well, i'm gonna wait for the official update of Lion, which will be soon, then i will go back in and delete this beta Lion partition.
     

Share This Page