Help deleting partitions and install Lion

Discussion in 'macOS' started by cjs1489, Sep 16, 2011.

  1. cjs1489 macrumors newbie

    Joined:
    Sep 15, 2011
    #1
    Problem 1

    When I try to delete partitions in disk utility it tells me that it cannot unmount them, the same thing happens when I try to erase my entire hard drive. I used to have rEFIt on my computer with Linux using the other 2 partitions.

    I have wiped every hard drive clean in my attempt to remove the partitions but have had no luck, this also caused my second problem.


    Problem 2

    I have no operating system on my computer. I burned the dmg for lion onto a dvd but my mac doesn't want to boot off the dvd it only wants to run of "Restore HD" which redirects me to go buy lion, something I was trying to avoid doing.

    I burned the image onto the dvd, hoping that was the correct way to do it, maybe I'm wrong. I also burned a copy using disk utility, but neither copy works.

    Can someone please help me, I worked on this all yesterday and got nowhere, probably even when backwards.
    Thanks in advanced.
     
  2. cjs1489 thread starter macrumors newbie

    Joined:
    Sep 15, 2011
    #2
    If anyone else is having this problem I figured out how to fix it though, it is a little convoluted.

    I booted of Linux and erased all the partitions of it it from there. My problem was that I couldn't unmount my hard drive because I was using it. So after booting of the Ubuntu cd I was able to go in and erase the partitions from there and reformat a majority of the drive (not EFI or Recovery HD) to FAT. I then could run Restore HD and reformat the drive from there into Mac OS Extended.

    That solves problem 1

    As for problem 2 I'm still working on, I am going to start over with snow leopard, and will be writing that to a USB drive with the help of this guide
    http://osxdaily.com/2009/09/02/inst...or-how-to-upgrade-to-106-without-a-dvd-drive/
    And then I will update to Lion with my cd which I realized only has the upgrade on it not the full version.

    I'll let you know if anything goes wrong/ it worked in case anyone else has a similar problem to mine.
     

Share This Page