Help Dial Pad not working after Jailbreak

Discussion in 'Jailbreaks and iOS Hacks' started by scott74, Aug 12, 2008.

  1. scott74 macrumors newbie

    Aug 12, 2008
    I just jailbroke the 3g iphone with 2.0.1 and installed customize an a few other things and now when I click on phone it does not say recent or favorites or anything at the bottom, cannot dial on the keypad and after about 5 seconds it goes back to the home screen. Does anyone have a fix for this.

  2. xsecretfiles macrumors 6502

    Aug 1, 2008

    I just realized my isn't working at all

    I don't know since when exactly. I haven't made many calls

    If I bring the phone app, it just crashes completely. I can answer calls, but the screen will go away, but I can still hear audio.

    I can dial by going through my contact ap.

    I will probably just restore when I get home :(:mad:
  3. LoMonkey macrumors regular

    Jul 4, 2008
    I had the same problem, but fixed it without restoring!

    I had this same exact problem and I was freaking out thinking I was going to have to restore again. Turns out, one of the packages I had installed through Installer 4 was the culprit. For me, it was Kate. Once I uninstalled Kate, it worked great! So try uninstalling the last couple of apps you installed before you noticed it wasn't working. Hope this helped!
  4. scott74 thread starter macrumors newbie

    Aug 12, 2008
    awesome, thanks, I already restored so I guess I will rejailbreak now.
  5. HouseofG macrumors member

    Jul 28, 2008
    You rock, LoMonkey. That was my issue as well. May still have to restore though, because uninstalling Kate also deleted Cydia, Installer and BigBoss Prefs (or at least the icons) from my phone!? And all the Poof hidden icons are back (which is what makes me think, Cydia, etc. may still be around but lost the musical chairs game when all poofed apps came back).
  6. nerdess macrumors newbie

    Jul 19, 2008
    This was VERY helpful! I had this happen a couple of weeks ago (seemed to have happened when my battery died mid-doing-something...) I restored and all was well... but last night I was messing around with installed and cydia... installed Kate among other things... and this am - couldn't dial (except via contacs)

    I removed kate as suggested and all is right in my world again!
  7. ignus graius macrumors regular

    Dec 4, 2005
    Same thing happened to me--Kate was the culprit as well.
  8. jcde7ago macrumors 6502


    Aug 4, 2008
    San Francisco, CA
    Stay away from Installer and anything from RiPDev. That's the best advice I can give you guys ;).
  9. TheBold macrumors member

    Aug 21, 2008
    In addition to what you guys have said, the Winterboard will cause the same in some cases.
  10. jcde7ago macrumors 6502


    Aug 4, 2008
    San Francisco, CA
    This is the first i have heard of it. Winterboard doesn't touch anything but theming image files using MobileSubstrate. I can assure you your case is an anomaly, as after visiting about 7-8 iPhone hacking forums regularly, i have never once heard of WinterBoard causing the phone app/dialpad not to work. If this is happening to you, something else is the culprit....i've been jailbroken for a longgg time and have never had any issues with anything that Saurik (developer of Cydia and God of the jb world) has created.
  11. godfather5800 macrumors newbie

    Nov 30, 2008
    The same thing happened to me the first two times I installed Winterboard, but the third time around it worked fine. I wish I knew what changed between time #2 and time #3.
  12. CR0907 macrumors newbie

    Nov 16, 2011
    Dial screen not working

    My dial screen and calculator got 3x smaller when I accidentally exited Cydia during essential updates. There were like 20 updates so I don't really remember exactly what was updated. If I just reinstall everything one by one would that fix the issue or what should I do? Thanks

Share This Page