HELP!!! Did I just kill my iMac???

Discussion in 'Mac Basics and Help' started by thunderclap13, Aug 19, 2008.

  1. thunderclap13 macrumors newbie

    Joined:
    Aug 19, 2008
    #1
    hi all

    new to the forum here, so hello to everyone. i apologize in advance for the long-winded nature of this post, but i wanted to include as many details as possible.

    i am writing because i have a potentially very big problem, caused by a possibly quite ill-advised attempt at a do-it-yourself replacement of both the hard drive and CD-R/DVD optical drive in my 'desk-lamp' model G4 iMac, which i've had for several years. it's done an admirably reliable job for me over those years, but in recent months has gotten painfully slow at times and has frozen up on me at start-up on one or two occasions, at the grey screen with the apple icon with the loading icon underneath, which after some research i learned was a sign that the hard drive might be crapping out. so, since i wanted to upgrade the original 40gb HD anyway, i figured i may as well replace the hard drive entirely, with a new 160gb Seagate model i purchased from a (fairly reputable, i think) online merchant. i also replaced the original CD-R/DVD drive with a new Pioneer CD-R/DVD-R drive. as far as i know, both of these drives are brand new, as in never used and not refurbished.

    then, using guides i found online, i proceeded to attempt the surgery, which went well as far as i could tell, insofar as there were no huge discharges of static electricity (i was wearing a grounding bracelet) and i didn't outright snap anything in half. i reconnected the optical and hard drives in the same configuration as their predecessors, which i believe had the optical drive as 'master' and the hard drive as 'slave' (though i'm not 100% sure, since i'm not entirely clear on how to tell which is which), and made sure to keep track of all the wires i disconnected so that i could reconnect them at the end. however, there is a connecting piece at the right side of the base that makes it rather difficult to separate the bottom part (which houses the motherboard) from the top part (or dome) that contains the HD and optical drive. i mention this because i'm not entirely sure i was able to get this to properly reconnect when i screwed the bottom back on, though i tried my damnedest (and i'm thinking that maybe i wouldn't be able to screw it back on if it didn't reconnect?), and i'm thinking this might be a source of the trouble.

    anyway, the end result is that my iMac now will turn on when i press the power button, and make the nice, soothing start-up sound, before it proceeds to one of two screens, depending on what button(s) i press on the keyboard during start-up:

    * if i do not press any keys, it goes to the flashing question mark screen;

    * if i hold down the 'alt' key during start-up, it goes to a grey screen that has two buttons in the middle of it: the one on the left has a circular arrow suggesting it causes a re-start (and indeed, when i do click on it, the little ticking watch icon appears, so it seems as though it's re-starting, or at least mulling something over), and the button on the right has a straight arrow pointing to the right, which seems like it's inviting me to some wondrous next screen but has absolutely no effect when i click on it.

    here's the most troubling bit: i have tried re-setting the PRAM by holding down option+control+P+R right after start-up but before the grey screen, with no effect (goes straight to flashing '?' screen). i have also tried holding down the mouse button during start-up, in an attempt to get the CD tray to open, with no effect (again, flashing '?' and the tray stays closed). through random experimentation i have found that almost any key i hold down during start-up gets me the flashing '?' screen, with the exception of the 'alt' key as mentioned above. one exception is that when i hold down the 'T' key, i get a start-up sound but no screen at all, and eventually the computer shuts back down by itself.

    obviously, my mouse (which i have connected to the USB port on my keyboard which is in turn connected to the PC) is working, so that i can move around the cursor on the circular arrow/straight arrow alt-induced screen and press either of the two buttons with the above-mentioned (non-)effects. as endlessly fun as that is, i would prefer a little bit more functionality from my computer, and so i was hoping somebody here would be able to help me. did i kill my mac? please help!!!
     
  2. SnowLeopard2008 macrumors 604

    SnowLeopard2008

    Joined:
    Jul 4, 2008
    Location:
    Silicon Valley
    #2
    Did you reinstall the os on the hard drive, because the flashing icon means it can't detect an operating system on the startup drive.
     
  3. PcBgone macrumors 6502

    PcBgone

    Joined:
    Feb 3, 2008
    #3
    Did you put in your hard drive straight in from the box? Or did you format it first? That ? mark screen is stating its not reading the hard drive, but if you didnt format the harddrive then thats why it cant read it. Do you have your install disks? Can you boot from those disks?
     
  4. aross99 macrumors 68000

    aross99

    Joined:
    Dec 17, 2006
    Location:
    East Lansing, MI
    #4
    Actually, this sounds like exactly what you should get. You need to format the drive and install OS X, and then you should be good to go - assuming you have everything you need from your OLD hard drive.

    As someone said above, the blinking Question mark means OS X isn't loaded yet...

    Did you backup the info you need from the old drive?
     
  5. thunderclap13 thread starter macrumors newbie

    Joined:
    Aug 19, 2008
    #5
    thanks for the responses guys.

    i know that the flashing '?' means the computer can't find the OS, however, since i can't get the CD tray to open, I don't know how to install the OS. I do have all the install/Start-up disks that originally came with the iMac, as well as a copy of OSX Tiger on DVD, so if i could figure out how to get the computer to open up the tray for me and read them, that might do the trick.

    i did not format the hard drive, and it seems likely that that could also be part of the problem. i assumed that the computer would recognize the unformatted hard drive and then prompt me to format it, but it's not doing that. is there any way to format the hard drive without using one of the install disks?

    i did back up all of my application software and documents onto an external hard drive. is there any other info that i should have backed up??

    thanks again, i really appreciate the help.
     
  6. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #6
    You have the right to remain silent....
     
  7. Schtumple macrumors 601

    Schtumple

    Joined:
    Jun 13, 2007
    Location:
    benkadams.com
    #7
    Ok, you need to press and hold the eject key on the top right hand side of the keyboard in order to open the cd tray, then insert the Mac OSX Tiger CD, restart the mac and then press and hold the C key for several seconds (I've found sometimes it doesn't register, so it's best to hold it for 5 seconds, then let go, then 5 seconds again, etc) until it boots from the CD, from there, you will then be able to format the hard drive and install Mac OSX.
     
  8. thunderclap13 thread starter macrumors newbie

    Joined:
    Aug 19, 2008
    #8
    thank you schtumple. in the process of all this, i did try to open the CD tray by holding down the eject key (i'm not a total retard, just a semi-retard :)), but that didn't work. i then read on an apple support forum somewhere that i needed to actually hold the mouse button during start-up to get the tray to open, but that didn't work either. so i'm stumped as to how to get the CD tray to open. :(
     
  9. TuffLuffJimmy macrumors G3

    TuffLuffJimmy

    Joined:
    Apr 6, 2007
    Location:
    Portland, OR
    #9
    Why not try putting your old drive back in?
     
  10. thunderclap13 thread starter macrumors newbie

    Joined:
    Aug 19, 2008
    #10
    success!!

    it was all about the IDE configuration settings. i hadn't known to look to see what the default jumper settings were for the HD and optical drives before i installed them; once i took them out and re-installed with both set to cable select, with the optical drive as master and HD as slave, everything booted up beautifully. while i had the drives out to change the jumper settings, i force-opened the CD tray and placed my OSX installation DVD in, so that it would already be loaded up when i powered on, which i did while holding down the 'C' key. i have a feeling that the tray would have opened normally with the new configuration, but i didn't want to take any chances. the feeling of relief and gratification i got once i saw that apple icon against the grey screen was sublime. i now have OSX installed on my new hard drive and everything is working perfectly.

    one strange thing did happen, though. before doing any of this, i looked to see how my old HD and optical drives were configured, and found that the hard drive had its jumper set to master, and the optical drive was set to slave. so i tried re-installing both drives with this configuration, figuring that if it worked for the old drives it should work for the new. not so. this time, when i tried to boot up, all i got was a grey screen; it wouldn't even give me the flashing '?' icon. i did get the restart arrow/straight arrow screen when holding down the 'alt' key at power-up, but that was it. it was only after i once again removed the drives and set them both to cable select, this time with the optical drive as master, that things started to work. not sure what to make of that, but i don't much care which configuration it has to be in, as long as it works.

    anyway, i just wanted to let you all know how it worked out. thanks so much for all your help and advice, it really was invaluable, and i appreciate it greatly.

    cheers
    tc13
     

Share This Page