Help ejecting a disc

hurl everstone

macrumors newbie
Original poster
Jan 9, 2004
6
0
(Powerbook G4, running Tiger 10.4.2)
I've got a cd that refuses to eject in Itunes. I've tried restarting while holding down the trackpad, and restarting in Open Firmware. No luck either way. The "eject" icon shows up when I drag it to the trash, it makes all the normal "wanting to eject" noises, but then it just sticks and relaunches Itunes.

Any suggestions? Thanks.
 

hurl everstone

macrumors newbie
Original poster
Jan 9, 2004
6
0
Tried all that, still no luck

Open Firmware, restart while holding trackpad button, etc. Nothing works. It just sucks the cd back in and launches Itunes. Time to hit the repair shop, I guess?
 

jmort

macrumors member
Jun 10, 2005
52
0
Southern CA
Ya,

If you say you can hear it trying to eject, it doesn't sound like an issue with your computer being stubborn, but rather a bad disk or some physical damage that is preventing an eject.

It sounds to me like a repair shop would be the next option. Or, send it in to apple if you have applecare.


JM
 

alexstein

macrumors 6502a
Aug 23, 2004
736
1
i've had the same problem with my ibook g4 tried all kinds of things and the disc wouldn't come out.(the mechanism kicks in and you can here it operating but it can't eject the cd) brought it back to the apple store and they replaced my drive with a new one. took about 3 day's.but now it's working without any probelms.
 

pulsewidth947

macrumors 65816
Jan 25, 2005
1,106
2
The only other thing to try is terminal:

drutil tray eject
or
  1. Type the command drutil list into the Terminal and press return . This will provide a list of all currently connected removable devices. -- connect FireWire/USB drives for this
  2. Use the command drutil tray eject 1

From this site. Although the problem does sound mechanical if none of the other techniques will work.
 

AlBDamned

macrumors 68030
Mar 14, 2005
2,626
0
Can we assume that no reply from Mr Hurl means he got the disc out anyway?

Or maybe he's sent it off... who noes?
 

hurl everstone

macrumors newbie
Original poster
Jan 9, 2004
6
0
No luck yet

Thanks for all the input, but ye olde cd is still in there. Itunes is functioned just fine other than this annoyance. I'm hoping not to have to take the sucker to the shop, but it's looking that way...