HELP: Error 1600 and 21 jailbreaking

Discussion in 'Jailbreaks and iOS Hacks' started by bly2425, Oct 12, 2008.

  1. bly2425 macrumors newbie

    Joined:
    Oct 12, 2008
    #1
    I use PwnageTool 2.1 and iTunes 8.0.1 (11) to help jailbreak a friend's phone on my computer. She has a T-Mobile sim card.

    So I did the pwnagetool magic. You know the drill. And then I tried to restore the custom firmware that's generated. Error 1600.

    So I used the official restore to 2.1 (official version). Then enter DFU mode. Restore and Error 1600. (This method worked on my own phone though)

    Puzzled, I put the phone into recovery mode. Restore. Error 21.

    I am stuck now. Please help?
     
  2. Opie macrumors 6502a

    Opie

    Joined:
    Jun 17, 2008
    #2
    Try deleting the pwnage tool from your comp. then restart your comp and Do a DFU restore on her iphone and do not sync anything to it.Re download pwnage tool Then run pwnage tool again on her iphone and see if you have better luck. Also make sure you do expert mode and that you select the original iphone. Good Luck
     
  3. ntrigue macrumors 68040

    ntrigue

    Joined:
    Jul 30, 2007
    #3
    This has something to do with multiple iPhones on one computer. I encountered it as well.
     
  4. bly2425 thread starter macrumors newbie

    Joined:
    Oct 12, 2008
    #4
    So can I get rid of this problem by doing this on a different computer?
     
  5. domness macrumors 6502a

    domness

    Joined:
    Jan 14, 2008
    Location:
    Sheffield, UK
    #5
    I went through this problem a while back. There was a few pages on people trying to solve it. Eventually we all found out how to do it in our own ways. It would do no harm to do a LITTLE searching around the forums. There are plenty of topics already about 160x errors.
     
  6. bly2425 thread starter macrumors newbie

    Joined:
    Oct 12, 2008
    #6
    I did. And I only posted the thread after all the possible solutions have been tried. The most common way is to use recovery mode, which returns error 21. I tried downgrading. Error 1600 then 21. Any ideas?
     
  7. jackiecanev2 macrumors 65816

    jackiecanev2

    Joined:
    Jul 6, 2007
    #7
    I just did a friend's phone with the same problem this afternoon. Just keep trying. Eventually one will take. Switching back and forth between DFU and restore seems to work for most people. You could always try creating another custom firmware, and "jiggle" it around a little. Some people swear by uninstalling and reinstalling itunes, switching DFU/restore, reinstalling pwnage, etc.
     
  8. chiclops macrumors newbie

    Joined:
    Oct 8, 2008
    #8
    Finally fixed my "Error 21" problem... If you are getting "Error 21", then the problem is that you are ending up in Recovery Mode and not in DFU Mode. See here:

    http://thebigboss.org/guides/dfu-mode/

    Not sure if you can get into DFU Mode directly once your iPhone is in recovery mode, but what did work for me was to do a normal restore (to 3.0), then put the phone in DFU mode, then follow the instructions to downgrade to 2.2. Be sure to confirm you end up in DFU mode this time.

    Hope this helps others.
     

Share This Page