help! f1-f9 keys and right shift not working

Discussion in 'MacBook' started by captaindaniel, Oct 9, 2009.

  1. captaindaniel macrumors newbie

    Joined:
    Oct 9, 2009
    #1
    Have already gone to system preferences and made sure "use f1 f2 keys as standard function keys" was unchecked. I've tried checking it and then unchecking it and at some points it has corrected itself and then the problem eventually returns. Any ideas?
     
  2. Battlejuice macrumors newbie

    Joined:
    Nov 13, 2010
    #3
    This is an incredibly infuriating problem.
    Have a Mac Mini running 10.5.8 using a wireless aluminum 2007 keyboard and this problem suddenly kicked in.
    I'm guessing it's as a result of an update but hard to pinpoint when exactly this started happening.
    Tried enabling/disabling the 'Use all F1,F2, etc' option under the keyboard and mouse settings but no change.
    Would love to be able to roll that last few updates back or get under the hood of the keyboard preferences as repairing the keyboard does nothing.
    Have been trawling the web for any solution to this but no joy at all.
    Disappointing, have learned the lesson of not upgrading when everything works perfect (if it ain't broke don't fix it and all that)
     
  3. aonelas macrumors newbie

    Joined:
    Nov 14, 2010
    Location:
    Honolulu
    #4
    Same problem

    My keyboard just started doing the same thing (i'm using a spare at the moment). ESC, F1-F9, and right shift. Have any of you taken it in to the Apple Store? Did they replace it?

    Thanks

    Aaron
     
  4. AlphaDogg macrumors 68040

    AlphaDogg

    Joined:
    May 20, 2010
    Location:
    Boulder, CO
    #5
    Everyone with the issue: If you are not running snow leopard, then go out and buy a snow leopard install disc for $30. Then install it, and update to the latest version of snow leopard (10.6.6). Good luck.
     
  5. pmcorcoran macrumors newbie

    Joined:
    May 7, 2012
    #6
    i have this same problem and am running on a 2009 MacBook Pro with 10.6.8 so the latest version of snow leopard does not fix this.... anyone have a fix for this? Its very annoying!
     

Share This Page