HELP! Final Cut Pro 3 "System ID file" error!

Discussion in 'Mac Apps and Mac App Store' started by rassoodock, Sep 17, 2007.

  1. rassoodock macrumors member

    Joined:
    Jan 22, 2007
    #1
    I'm trying to sort out a problem with installing Final Cut Pro 3 on my G5 running OSX 10.4.10 and Quicktime Pro 7. I know it's on older version of Final Cut Pro, but I don't need a ton of features and I bought this one used so it would be cheaper.

    When I first tried to run the program after installing, it says I need a System ID file (IMAGE 1 - see below). I tried to re-install as suggested, but it didn't work. Searching the web, I found a suggestion that I update to the current version. However, this would not work because the "CD-Rom" had not been authenticated (IMAGE 2 - see below). I have never been able to get to a screen that would allow me to authenticate or proceed any further.

    Can anyone help me figure this out? I am totally stuck.:confused:

    Thanks,
    Michael

    IMAGE 1
    http://www.rassoodock.com/fcpro-1.jpg

    IMAGE 2
    http://www.rassoodock.com/fcpro-2.jpg
     
  2. Cromulent macrumors 603

    Cromulent

    Joined:
    Oct 2, 2006
    Location:
    The Land of Hope and Glory
    #2
    Final Cut Pro 3 was written to work on Mac 9.2.2 or Mac OS X 10.1.1. The chances of their being incompatibilities introduced since then are huge. As to the problem I have no idea I am afraid.
     

Share This Page