Help...Finder crashes nonstop!!!

Discussion in 'macOS' started by expergo, Mar 12, 2008.

  1. expergo macrumors regular

    Joined:
    Nov 21, 2004
    #1
    Hi,

    I have the latest iMac model. All of a sudden my comp froze so I turned it off and turned it back on. After I log on, Finder keeps on crashing (there's a log) and there's no way to stop it. I only have one user on it so I can't test it with another user. I trashed the finder.plist and same thing. I restarted in Safe Mode and still the same thing. Anyone have any idea what's going on? This is with 10.5.2.

    Really need my computer this time of year!! :(
     
  2. phenixbleu macrumors member

    Joined:
    Feb 12, 2008
    #2
    Try This

    Okay the only advise I could give you is to check for updates, run maintance scripts in terminal : sudo periodic daily weekly monthly then enter password and wait till it show your mac and username. I would adive you download Mainmenu and you can run all maintaince from it. Its very safe so do not worry.I would advise you to backup also.

    Phenixbleu
     
  3. expergo thread starter macrumors regular

    Joined:
    Nov 21, 2004
    #3
    Hey,

    I ran all the maintanence stuff and it still doesn't work. I put it in Target disk mode and booted it from another Mac and still the same problem so I'm pretty sure it's a software problem.

    I can upload the crash log if anyone wants to see. I just don't get how one second it could all of a sudden crash. Is there anywhere to just reinstall the finder?
     
  4. live4ever macrumors 6502a

    Joined:
    Aug 13, 2003
    Location:
    Thunder Bay, ON
    #4
    Definitely need to do an archive/install or an erase/install.
     
  5. CJRhoades macrumors 6502

    Joined:
    Dec 4, 2007
    Location:
    Lafayette, IN
    #5
    Yep.... sounds like it's time for a reinstall.
     
  6. applefan69 macrumors 6502a

    applefan69

    Joined:
    Oct 9, 2007
    Location:
    Medicine Hat
    #6
    that really sucks, my theory is finder became corrupt. It's one of those rare but unpreventable, and inevitable problems that harddrives give us.
     
  7. expergo thread starter macrumors regular

    Joined:
    Nov 21, 2004
    #7
    Aiya. Thanks guys. I guess I'll do an archive and install. Does that keep my apps too?
     
  8. expergo thread starter macrumors regular

    Joined:
    Nov 21, 2004
    #8
    Okay, did an archive and install and everything works now. Weird thing is when I tried to backup with TM using the same disk, it erased all my previous TM backups except the latest one.
     

Share This Page