Help - Firewire / Input manager Kernel Panics?

Discussion in 'Mac Basics and Help' started by benseven, Jan 6, 2009.

  1. benseven macrumors newbie

    Joined:
    Jan 6, 2009
    #1
    Hi all,

    I'm an experience Mac user but this has me stumped. I am having anything from 0 to 4 Kernel Panics a day on my 1st Gen Macbook 2.0GHz all with the same crash report:

    Code:
    Sun Jan 4 00:37:39 2009
    panic(cpu 1 caller 0×0019D6C3): “simple lock deadlock detection: lock=0×3e18108, cpu=1, owning thread=0xb457998”@/SourceCache/xnu/xnu-1228.7.58/osfmk/i386/locks_i386.c:317
    Backtrace (CPU 1), Frame : Return Address (4 potential args on stack)
    0×5026be48 : 0×12b0fa (0×459234 0×5026be7c 0×133243 0×0)
    0×5026be98 : 0×19d6c3 (0×460cbc 0×3e18108 0×1 0xb457998)
    0×5026beb8 : 0×82e4cc (0×3e18108 0×0 0×5026bed8 0×8381a8)
    0×5026bed8 : 0×82f669 (0×5026bf00 0×212 0×5026bf28 0×838949)
    0×5026bf08 : 0×82f893 (0×3e18000 0×3daf304 0×5026bf58 0×3e18000)
    0×5026bf28 : 0×832018 (0×3e18000 0×2e52a1e4 0×0 0×8000)
    0×5026bf48 : 0×83e33e (0×3e18000 0×3e328a4 0×5026bf78 0×136ac0)
    0×5026bf68 : 0×41fa80 (0×3e32880 0×0 0×5026bfc8 0×13ebef)
    0×5026bf98 : 0×41f762 (0×3e32a80 0×0 0×5026bfc8 0×3daf2e8)
    0×5026bfc8 : 0×19eccc (0×3e32a80 0×0 0×1a20b5 0xb457998)
    Backtrace terminated-invalid frame pointer 0
    Kernel loadable modules in backtrace (with dependencies):
    com.apple.driver.AppleFWOHCI(3.4.4)@0×82d000—>0×84cfff
    dependency: com.apple.iokit.IOFireWireFamily(3.4.4)@0×7ee000
    dependency: com.apple.iokit.IOPCIFamily(2.4.1)@0×5c1000
    
    BSD process name corresponding to current thread: kernel_task
    
    Mac OS version:
    9F33
    
    Kernel version:
    Darwin Kernel Version 9.5.0: Wed Sep 3 11:29:43 PDT 2008; root:xnu-1228.7.58~1/RELEASE_I386
    System model name: MacBook1,1 (Mac-F4208CC8)
    My Firewire port has also ceased working. I've tried doing backups and re-installing Leopard, still no luck. I'm loathed to have to go to the Apple store in Glasgow as that's a train journey and money spent when there *could* be a solution from someone online.

    Thanks in advance,

    Ben
     
  2. BlueRevolution macrumors 603

    BlueRevolution

    Joined:
    Jul 26, 2004
    Location:
    Montreal, QC
    #2
    Have you run Hardware Test? A kernel panic usually means something is amiss.
     
  3. Bluisnblklungs macrumors member

    Joined:
    Jul 29, 2008
    #3
    I was having the same problem at first i thought that i was my 3rd party ram but before i went out and spent another $50 or so i thought that i would take it in to the genius bar and let them have a look. He told me that it might be my ram or my firewire. So i went and picked up a $10 firewire and i have not had a panic sense. If it only crashes when you have the firewire plugged in then i would go the cheaper route and see if that fixes it for you if not it might be bad ram.
     
  4. benseven thread starter macrumors newbie

    Joined:
    Jan 6, 2009
    #4
    Hi, thanks for your reply.

    I ran hardware test this morning, both extended and normal tests, and it found nothing to report. This is very strange.

    Thanks for your reply. However, I don't quite follow what you mean when you say you bought a $10 Firewire. A firewire what?

    Nothing happens when I plug in Firewire devices - the system doesn't even recognise something is plugged in and the Hard drive or whatever device doesn't fire up.

    I think if it was dodgy RAM (which has been running fine for 2+ years) then hardware test would have picked it up.
     
  5. BlueRevolution macrumors 603

    BlueRevolution

    Joined:
    Jul 26, 2004
    Location:
    Montreal, QC
    #5
    Yes it would have. That's what the extended test specifically examines.

    Since the problem has carried over between installs, I would say the problem is still hardware but something that hardware test is unable to pick up on. Since it's not a common problem, that means that it will be next to impossible for a mere mortal to diagnose, let alone fix. Sorry to say, but you're going to have to take it in to the shop.
     
  6. benseven thread starter macrumors newbie

    Joined:
    Jan 6, 2009
    #6
    Well, thanks for your help. At least we have ProCare so I can get to the shop and not have to wait. There's a couple of other things that have been funny about the machine that hopefully I can talk to them about too.

    B
     
  7. Sun Baked macrumors G5

    Sun Baked

    Joined:
    May 19, 2002
    #7
    Could very well be the FW device, there were some changes in 10.5.6 that could have pushed even more of the devices into needing a firmware update.

    Seems FW has been a thorn in Apple's side for awhile, hopefully Snow Leopard fixes some lingering issues.

    Doubtful it'll fix the Time Machine/FW issue driving people to USB drives.
     
  8. benseven thread starter macrumors newbie

    Joined:
    Jan 6, 2009
    #8
    Thing is, I'm on 10.5.5 - just haven't got around to the update yet.

    Interesting to hear TM was causing issues though - I was previously using my Time Machine drive over FW until it stopped working...
     

Share This Page