Help Fixing NTFS terminal commands please

Discussion in 'MacBook Pro' started by Jessec80, Aug 11, 2013.

  1. Jessec80 macrumors newbie

    Joined:
    Aug 11, 2013
    #1
    I have a windows formated external hard drive (NTFS) that I wanted to write to on my mac. So I searched around forums for advice for a while and tried writing a few things in terminal. But it didn't work. In fact, it made it worse. Now my external drive doesn't show up on desktop, or /Volumes. But I can find it in Disk Utilities. Although, the drive won't mount now. So now I can't read or write!

    The issue with mounting started after I wrote these in terminal:
    cd /sbin
    sudo mv mount_ntfs mount_ntfs.orig
    ls <<confirm and="" file="" have="" mount_ntfs="" mount_ntfs.orig="" no="" that="" the="" you="">>
    sudo chown root:wheel mount_ntfs
    sudo nano mount_ntfs

    In the nano window I wrote:
    #!/bin/sh
    /sbin/mount_ntfs.orig -o rw "$@"

    conrol X saved, Y and enter
    Then I wrote:
    sudo chown root:wheel mount_ntfs
    sudo chmod 755 mount_ntfs

    This is all according to the advice I used from http://www.macbreaker.com/2012/02/enable-write-for-ntfs-hard-drives-on.html
    Scroll down to the newest comment for the terminal commands advice.

    After reboot I could no longer mount the external hard drive. So I went back into terminal and deleted the line in nano mount_ntfs #!/bin/sh
    /sbin/mount_ntfs.orig -o rw "$@" thinking that might fix it. But it did not.

    Can anyone help me figure out how to fix the mounting issue?

    When I use terminal: mount it shows:

    /dev/disk0s2 on / (hfs, local, journaled)
    devfs on /dev (devfs, local, nobrowse)
    map -hosts on /net (autofs, nosuid, automounted, nobrowse)
    map auto_home on /home (autofs, automounted, nobrowse)

    diskutil list:

    /dev/disk0
    #: TYPE NAME SIZE IDENTIFIER
    0: GUID_partition_scheme *500.1 GB disk0
    1: EFI 209.7 MB disk0s1
    2: Apple_HFS Macintosh HD 499.2 GB disk0s2
    3: Apple_Boot Recovery HD 650.0 MB disk0s3
    /dev/disk1
    #: TYPE NAME SIZE IDENTIFIER
    0: FDisk_partition_scheme *1.0 TB disk1
    1: Windows_NTFS TOSHIBA EXT 1.0 TB disk1s1

    The TOSHIBA EXT is the drive that's causing problems.

    Also I should probably add that I tried to use terminal before to make it possible to write on the disk. Which also didn't work.

    I used fstab file:

    sudo nano /etc/fstab

    and entered various lines as per advice from online. At first I tried LABEL=TOSHIBA_EXT none ntfs rw,auto,nobrowse

    which did nothing. I thought I was getting the name of the hard drive wrong. So I went back in and changed it to

    UUID=6F0E3B76-834A-4C96-94E8-F9D30D159451 none ntfs rw

    This is what caused my hard drive to initially disappear from the desktop. But I could still find it by through open /Volumes or in disk utility. but I could still read but not write on it.

    :(I am giving up on terminal for this issue. I would like to go back to the mac's original settings so I can just use a 3d party app for ntfs writing.

    But this problem of not being able to mount it at all is really troubling. Does anyone know how to fix this?:confused:

    ----------

    I guess I should add I'm using OS 10.8.4
     
  2. tag macrumors 6502a

    tag

    Joined:
    Apr 29, 2005
    Location:
    PA, US
    #2
    Let me start by saying, from my research, I would advise against enabling native write support (via terminal like you tried to do) as there are a number of instability issues which I came across. In the end I ended up using the combo of Fuse for OSX, NTFS-3g, and the fuse-wait patch (to correct the timeout error on 10.7+) and reading/writing to NTFS drives works flawlessly for me on 10.8.4.

    Now back to your problem. From what I've gathered from what you wrote, you didn't totally understand what those files did, as from what I'm reading you essentially completely stopped mount_ntfs from running at all, which is causing your no mount issue.

    What you basically did was rename the original binary mount_ntfs file, create a new mount_ntfs as a script in which you refer back to the old file while giving it read/write authority. Then you went in to try and fix your problem by deleting the contents of the new mount_ntfs script file, and now you have no reference to the original mount_ntfs file to mount the ntfs hard drive. So....

    The easiest way to fix this is to delete the new mount_ntfs file (not just deleting the contents), and then rename back the mount_ntfs.orig to mount_ntfs.

    The fix should be quick and easy, but the following is going to be a bit simplified and long, as I don't want you messing anything up and thus making things more difficult for you.

    Now before you go doing this let us just verify that the old file is intact before we go moving things around. (If at anytime something is off from my instructions please stop and let me know, unless you know exactly yourself why the deviation occurred.)

    Open terminal and do the following....

    - Verify that the old mount_ntfs file is still there by typing 'file /sbin/mount_ntfs.orig'

    - You should get back something like 'mount_ntfs.orig: Mach-O 64-bit executable x86_64'

    - If that file is still there, lets check to make sure that the new mount_ntfs is indeed an empty script file like I think it is, type 'cat /sbin/mount_ntfs'

    - If there is no output from that command, then we are good to go to the next step, if there is output (or anything other than #!/bin/sh or that other line your originally wrote) please let me know.

    - To be a bit safer here we will move into the sbin directory so type 'cd /sbin'

    - Now we are going to remove the new file you created, type 'sudo rm mount_ntfs'

    - Now we are going to move the old file back to its original name, type 'sudo mv mount_ntfs.orig mount_ntfs'

    - Now restart your computer and the drive should be mountable again as it was before you started messing about with the terminal.


    On another note, you said that you edited your fstab in another attempt to try to enable native write support. Is that line which you entered still in your fstab file? If so you may want to delete that line before trying to install NTFS-3g or other 3rd party ntfs driver, just so there are no conflicts.
     
  3. Jessec80 thread starter macrumors newbie

    Joined:
    Aug 11, 2013
    #3
    You fixed it! Thank you! The external hdd mounts automatically and shows up on desktop when I plug it in. It's like I never messed with any of the files. What a relief! You are right, I did not really understand what I was doing. I've had some luck using terminal to change things before, but this ntfs write business went awry. I'm going to read up on using terminal before I go messing around with it again.

    I'll dl NTFS-3G
     
  4. Monik02 macrumors newbie

    Joined:
    Feb 13, 2014
    #4
    I used the terminal for activating the w/r in an external disk

    Hi!

    I have the same problem as Jessec80, but the difference is that I do not have the file mount_ntfs.orig, it says:

    /sbin/mount_ntfs.orig: cannot open `/sbin/mount_ntfs.orig' (No such file or directory)

    and then with the line 'cat /sbin/mount_ntfs' it shows a lot of characters like trash.

    At the very beginning I wanted to make my disk be read and written in mac, so I used the command sudo nano /etc/fstab and then LABEL=OneTouch4 none ntfs rw,auto,nobrowse. At the beginning it worked perfect, but I could use it just as a “hidden“ disk because it never appeared again in the finder, so I used a command to make it appear in a folder named volumes in the desktop. I do not what happened, but now I cannot see the files it is like the disk is empty even though in the information it shows the real space used and available.

    Please Tag, do you know how to fix this please?
     

Share This Page