Help Flashing a Sapphire 5870 for Mac Pro 4,1

Discussion in 'Mac Pro' started by benderbends, Oct 19, 2010.

  1. benderbends macrumors newbie

    Joined:
    Jul 31, 2007
    #1
    I have no idea what im doing, and think I may have fudged myself severely. Just spent a crap load on a 5870 PC version,......and now am lost on how to use it in my Mac Pro 2009 (4,1).

    I read through the "golden Guide" and some of the Netkas forums, but I'm still confused since there is so many versions and tools and requirements.

    Hoping some kind soul can give me a direct tutorial for my setup..and for the easiest path to success....

    Mac Pro 2009 Quad Core 2.66 Ghz (4,1)
    1 monitor = 32" LCD TV via DMI>HDMI
    currently a GT 120 installed.
    purchased the Sapphire 5870 HD as pictured below, along with the mac cables needed from OWC.

    I know how to plug it into the MacPro now...but how do i get it working for:
    - Bootcamp Windows 7?
    - Native boot OS X 10.6.4?



    EDIT: if a mod can help fix my typo in thread title please? ... should be 5870 not 5807
     

    Attached Files:

  2. mypetfrog macrumors newbie

    Joined:
    Feb 27, 2008
    #2
    Any followup? did it work?! How hard was it?!

    Hi,

    did you ever get any help with this? KNow of any tutorials?

    I'm just about to buy a XFX 5870 PC card and going to install in my 2008 MacPro 8core... the netkas site looks kinda scary and not sure if I'll need any other cables to power the 5870 after removing the installed 8800GT.

    Any thoughts?

    Does it boot OK, even with blank screens etc?
    Do software updates work ok? (does Mac see the card as a native mac 5870?)
    I presume it has to be flashed in windows (i do have a bootcamp partition) prior to setup in the mac

    Look forward to any thoughts and advice :)

    Thanks.
     
  3. Cindori macrumors 68040

    Cindori

    Joined:
    Jan 17, 2008
    Location:
    Sweden
    #3

Share This Page